summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLoïc Minier <lool@dooz.org>2007-09-30 16:44:54 +0200
committerLoïc Minier <lool@dooz.org>2007-09-30 16:44:54 +0200
commitfa2ab9cbb3615571bfbe635514fb1d8322aa0ff3 (patch)
tree41f5e88dbbe0720d1f53df3b4bc68b0e0319083d
parent0a5b0ff05b96ff1e2daa7e57cd4aeb7b6ddcb412 (diff)
Drop Debian specific exit codes for vconfig errors
* Use upstream exit codes instead. * Document this change in NEWS.
-rw-r--r--debian/NEWS12
-rw-r--r--debian/changelog4
-rwxr-xr-xvconfigbin8224 -> 0 bytes
-rw-r--r--vconfig.c14
-rw-r--r--vconfig.h0
-rw-r--r--vconfig.obin27944 -> 0 bytes
6 files changed, 25 insertions, 5 deletions
diff --git a/debian/NEWS b/debian/NEWS
new file mode 100644
index 0000000..3bd8a7e
--- /dev/null
+++ b/debian/NEWS
@@ -0,0 +1,12 @@
+vlan (1.9-3) unstable; urgency=low
+
+ * Error codes of vconfig back in sync with vanilla vlan: the vconfig
+ command was incorrectly returning a zero exit status up to upstream
+ release 1.9 of the vlan package. Starting with Debian version 1.9-1, the
+ Debian version of vconfig was modified to always return 1 on failure while
+ the upstream version of vconfig would return different error codes
+ depending on the actual error; these changes are now being dropped in
+ favor of compatibility with upstream error codes. See Debian #320452 for
+ the original report on broken exit codes.
+
+ -- Loic Minier <lool@dooz.org> Sun, 30 Sep 2007 16:33:40 +0200
diff --git a/debian/changelog b/debian/changelog
index 45ab0c7..69dc585 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -6,8 +6,10 @@ vlan (1.9-3) UNRELEASED; urgency=low
* Rewrite copyright file completely; some copyrights and licensing headers
are missing upstream and should be clarified with the help of upstream.
* Stop installing README; no useful additional information.
+ * Drop Debian specific exit codes for vconfig errors; use upstream exit
+ codes instead; document this change in NEWS.
- -- Loic Minier <lool@dooz.org> Sun, 30 Sep 2007 16:28:22 +0200
+ -- Loic Minier <lool@dooz.org> Sun, 30 Sep 2007 16:44:14 +0200
vlan (1.9-2) unstable; urgency=medium
diff --git a/vconfig b/vconfig
deleted file mode 100755
index 8cfcbcd..0000000
--- a/vconfig
+++ /dev/null
Binary files differ
diff --git a/vconfig.c b/vconfig.c
index 3721fcc..5057cfd 100644
--- a/vconfig.c
+++ b/vconfig.c
@@ -186,7 +186,8 @@ int main(int argc, char** argv) {
if_request.cmd = ADD_VLAN_CMD;
if (ioctl(fd, SIOCSIFVLAN, &if_request) < 0) {
fprintf(stderr,"ERROR: trying to add VLAN #%u to IF -:%s:- error: %s\n",
- vid, if_name, strerror(errno));
+ vid, if_name, strerror(errno));
+ exit(3);
}
else {
fprintf(stdout,"Added VLAN with VID == %u to IF -:%s:-\n",
@@ -200,7 +201,8 @@ int main(int argc, char** argv) {
if_request.cmd = DEL_VLAN_CMD;
if (ioctl(fd, SIOCSIFVLAN, &if_request) < 0) {
fprintf(stderr,"ERROR: trying to remove VLAN -:%s:- error: %s\n",
- if_name, strerror(errno));
+ if_name, strerror(errno));
+ exit(4);
}
else {
fprintf(stdout,"Removed VLAN -:%s:-\n", if_name);
@@ -210,7 +212,8 @@ int main(int argc, char** argv) {
if_request.cmd = SET_VLAN_EGRESS_PRIORITY_CMD;
if (ioctl(fd, SIOCSIFVLAN, &if_request) < 0) {
fprintf(stderr,"ERROR: trying to set egress map on device -:%s:- error: %s\n",
- if_name, strerror(errno));
+ if_name, strerror(errno));
+ exit(5);
}
else {
fprintf(stdout,"Set egress mapping on device -:%s:- "
@@ -223,6 +226,7 @@ int main(int argc, char** argv) {
if (ioctl(fd, SIOCSIFVLAN, &if_request) < 0) {
fprintf(stderr,"ERROR: trying to set ingress map on device -:%s:- error: %s\n",
if_name, strerror(errno));
+ exit(6);
}
else {
fprintf(stdout,"Set ingress mapping on device -:%s:- "
@@ -235,6 +239,7 @@ int main(int argc, char** argv) {
if (ioctl(fd, SIOCSIFVLAN, &if_request) < 0) {
fprintf(stderr,"ERROR: trying to set flag on device -:%s:- error: %s\n",
if_name, strerror(errno));
+ exit(7);
}
else {
fprintf(stdout,"Set flag on device -:%s:- "
@@ -246,7 +251,8 @@ int main(int argc, char** argv) {
if_request.cmd = SET_VLAN_NAME_TYPE_CMD;
if (ioctl(fd, SIOCSIFVLAN, &if_request) < 0) {
fprintf(stderr,"ERROR: trying to set name type for VLAN subsystem, error: %s\n",
- strerror(errno));
+ strerror(errno));
+ exit(8);
}
else {
fprintf(stdout,"Set name-type for VLAN subsystem."
diff --git a/vconfig.h b/vconfig.h
deleted file mode 100644
index e69de29..0000000
--- a/vconfig.h
+++ /dev/null
diff --git a/vconfig.o b/vconfig.o
deleted file mode 100644
index 8e8da0e..0000000
--- a/vconfig.o
+++ /dev/null
Binary files differ