summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorAndreas Henriksson <andreas@fatal.se>2016-01-06 18:42:14 +0100
committerAndreas Henriksson <andreas@fatal.se>2016-01-06 18:42:14 +0100
commit5941da738b84471b6eb89daf1427a80fa4934491 (patch)
tree1821561c26ff4ec9e575925118b81d78f1917fa7 /debian/rules
parent7517228145310a29b7cb7f4bddccb1b70df347eb (diff)
Import Debian version 2.0
vlan (2.0) experimental; urgency=medium * Non-maintainer upload. * Make this a native package and replace the previous upstream source with Andrew Shaduras vconfig compatibility script. (Closes: #501402) * Update package description to better describe this package content. * Rewrite debian/rules * Bump Standards-Version to 3.9.6 * Update debian/network/ contents to not rely on vconfig. - in preparation for potentian future dropping vconfig compat script. * Update debian/copyright for the new package content. * Make vconfig always print a deprecated notice to stderr when executed.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules39
1 files changed, 4 insertions, 35 deletions
diff --git a/debian/rules b/debian/rules
index 735776c..7f46fc6 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,38 +1,7 @@
#!/usr/bin/make -f
+%:
+ dh $@
-CCFLAGS += -Wall -g -O$(if $(findstring noopt,$(DEB_BUILD_OPTIONS)),0,2)
-
-binary-arch:
- dh_testdir
- dh_testroot
- dh_installdocs -s
- dh_installman -s
- dh_installchangelogs -s CHANGELOG
- dh_install -s
+override_dh_fixperms:
+ dh_fixperms
chmod -R 755 debian/vlan/etc/network
- dh_strip -s
- dh_fixperms -s
- dh_compress -s
- dh_shlibdeps -s
- dh_gencontrol -s
- dh_installdeb -s
- dh_md5sums -s
- dh_builddeb -s
-
-build:
- # upstream ships a macvlan_config binary
- #mv -f macvlan_config macvlan_config.orig
- # STRIP is to avoid the upstream stripping
- $(MAKE) CCFLAGS="$(CCFLAGS)" STRIP=true
-
-clean:
- # restore macvlan_config binary shipped by upstream
- #-mv -f macvlan_config.orig macvlan_config
- dh_clean
- rm -f vconfig.h vconfig.o vconfig
-
-binary-indep:
-
-binary: binary-arch binary-indep
-
-.PHONY: binary binary-arch binary-indep clean