summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog4
-rw-r--r--debian/network/if-up.d/ip2
2 files changed, 5 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index e2d0b4c..720b033 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -9,8 +9,10 @@ vlan (1.9-3.3) UNRELEASED; urgency=medium
* If VLAN is configured with higher MTU than raw device MTU, which can
happen if VLAN is ifup'ed before raw device, then increase raw device
MTU first so the VLAN ifup does not fail. (LP: #1224007)
+ * Allow ip-rp-filter to be 0, 1, or 2 instead of only 0 or 1
+ (LP: #1716964)
- -- Dan Streetman <dan.streetman@canonical.com> Thu, 08 Sep 2016 12:47:31 -0400
+ -- Dan Streetman <dan.streetman@canonical.com> Thu, 30 Mar 2017 09:16:10 -0400
vlan (1.9-3.2) unstable; urgency=medium
diff --git a/debian/network/if-up.d/ip b/debian/network/if-up.d/ip
index d7de05c..c155a7a 100644
--- a/debian/network/if-up.d/ip
+++ b/debian/network/if-up.d/ip
@@ -13,6 +13,8 @@ then
if [ -n "$IF_IP_RP_FILTER" ]; then
if [ "$IF_IP_RP_FILTER" -eq "0" ]; then
echo 0 > "/proc/sys/net/ipv4/conf/$IFACE/rp_filter"
+ elif [ "$IF_IP_RP_FILTER" -eq "2" ]; then
+ echo 2 > "/proc/sys/net/ipv4/conf/$IFACE/rp_filter"
else
echo 1 > "/proc/sys/net/ipv4/conf/$IFACE/rp_filter"
fi