summaryrefslogtreecommitdiff
path: root/script
diff options
context:
space:
mode:
authorRuben Undheim <ruben.undheim@gmail.com>2019-01-29 14:54:40 +0000
committerRuben Undheim <ruben.undheim@gmail.com>2019-01-29 14:54:40 +0000
commit8163cd837ed90bd66544bc349c1fec0c15347d9d (patch)
treecf8c44c5daba62d6a7bcda4fd17401f11e41aef5 /script
parent33eee9e9275f59d32e2920117a14d7d326b55eb8 (diff)
parent6dfbccb15630472233639bf2ad093493e90f3629 (diff)
Update upstream source from tag 'upstream/2.1.0'
Update to upstream version '2.1.0' with Debian dir e12d92e1c10a7537b138937bddbc7f9761f83c84
Diffstat (limited to 'script')
-rwxr-xr-xscript/bootstrap10
-rwxr-xr-xscript/release8
-rwxr-xr-xscript/setup10
3 files changed, 28 insertions, 0 deletions
diff --git a/script/bootstrap b/script/bootstrap
new file mode 100755
index 0000000..e5cf7f3
--- /dev/null
+++ b/script/bootstrap
@@ -0,0 +1,10 @@
+#!/bin/sh
+# Resolve all dependencies that the application requires to run.
+
+# Stop on errors
+set -e
+
+cd "$(dirname "$0")/.."
+
+echo "Installing test and release dependencies..."
+python3 -m pip install pytest pylint flake8 pydocstyle twine
diff --git a/script/release b/script/release
new file mode 100755
index 0000000..4b6bbcb
--- /dev/null
+++ b/script/release
@@ -0,0 +1,8 @@
+#!/bin/sh
+# Pushes a new version to PyPi.
+
+cd "$(dirname "$0")/.."
+
+rm -rf dist
+python3 setup.py sdist
+python3 -m twine upload dist/* --skip-existing
diff --git a/script/setup b/script/setup
new file mode 100755
index 0000000..554389e
--- /dev/null
+++ b/script/setup
@@ -0,0 +1,10 @@
+#!/bin/sh
+# Setups the repository.
+
+# Stop on errors
+set -e
+
+cd "$(dirname "$0")/.."
+script/bootstrap
+
+pip3 install -e .