summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRuss Allbery <eagle@eyrie.org>2014-07-23 14:13:30 -0700
committerRuss Allbery <rra@stanford.edu>2014-07-23 14:22:33 -0700
commit3c3edf2a386d07095e0b4b4bfc5f96c323eb6827 (patch)
tree3e26b74a1248ad581889f91e6f5ae9bcb23f58b8
parent1c20fc8222d18219c42423d29b148b8f29c17b30 (diff)
Bump shared library versioning
The change in the webauth_webkdc_config struct means that some interfaces are no longer compatible with previous releases. Be conservative and bump all of the library versioning. (Normally I wouldn't do an ABI bump in a minor release, but in this case the effect of the changes is very minor, just still an ABI break.) Change-Id: Ibbb515d7d9393f63751f11d05e5a135c1e3aa5dd Reviewed-on: https://gerrit.stanford.edu/1579 Reviewed-by: Russ Allbery <rra@stanford.edu> Tested-by: Russ Allbery <rra@stanford.edu>
-rw-r--r--Makefile.am2
-rw-r--r--lib/libwebauth.map2
2 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 86365365..28a02a21 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -160,7 +160,7 @@ EXTRA_lib_libwebauth_la_SOURCES = lib/krb5-heimdal.c lib/krb5-mit.c
lib_libwebauth_la_CPPFLAGS = $(AM_CPPFLAGS) $(APR_CPPFLAGS) \
$(APRUTIL_CPPFLAGS) $(REMCTL_CPPFLAGS) $(KRB5_CPPFLAGS) \
$(CRYPTO_CPPFLAGS)
-lib_libwebauth_la_LDFLAGS = -version-info 10:0:0 $(VERSION_LDFLAGS) \
+lib_libwebauth_la_LDFLAGS = -version-info 11:0:0 $(VERSION_LDFLAGS) \
$(APR_LDFLAGS) $(APRUTIL_LDFLAGS) $(REMCTL_LDFLAGS) $(KRB5_LDFLAGS) \
$(CRYPTO_LDFLAGS)
lib_libwebauth_la_LIBADD = portable/libportable.la $(APR_LIBS) \
diff --git a/lib/libwebauth.map b/lib/libwebauth.map
index e80934bb..cc7e0b97 100644
--- a/lib/libwebauth.map
+++ b/lib/libwebauth.map
@@ -1,4 +1,4 @@
-WEBAUTH_4_5 {
+WEBAUTH_4_6 {
global:
webauth_context_free;
webauth_context_init;