summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Millan <rmh@debian.org>2007-09-11 12:33:41 +0000
committerRobert Millan <rmh@debian.org>2007-09-11 12:33:41 +0000
commit98a7fbce709210c275b8060af17a6a43ccb199b2 (patch)
tree5235b4c23179995630cf43e9681c639767d6e2ce
parenta4b69e4489c9a77c8320177e4a732aa8631b185c (diff)
Implement support for loading README.html.
r49238
-rw-r--r--Makefile2
-rw-r--r--debian/changelog6
-rw-r--r--main.nsi16
3 files changed, 24 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 661d96d..8dbe51c 100644
--- a/Makefile
+++ b/Makefile
@@ -61,6 +61,8 @@ win32-loader.iso: win32-loader.exe win32-loader.ini autorun.inf \
todos < autorun.inf > netboot/autorun.inf
todos < win32-loader.ini > netboot/win32-loader.ini
cp win32-loader.exe netboot/
+ # this mimics the location of html docs in official CDs
+ echo "<html>hello, borg world!</html>" > netboot/README.html
genisoimage -r -J -o $@ netboot
netboot/install.386/vmlinuz:
diff --git a/debian/changelog b/debian/changelog
index 623af0b..cb2cb47 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+win32-loader (0.6.0~pre3) UNRELEASED; urgency=low
+
+ * Implement support for loading README.html.
+
+ -- Robert Millan <rmh@aybabtu.com> Tue, 11 Sep 2007 14:33:05 +0200
+
win32-loader (0.6.0~pre2) unstable; urgency=low
* Add reference to /usr/share/common-licenses.
diff --git a/main.nsi b/main.nsi
index 7e1abb1..546b491 100644
--- a/main.nsi
+++ b/main.nsi
@@ -27,6 +27,7 @@ OutFile "win32-loader.exe"
!include LogicLib.nsh
!include FileFunc.nsh
+!include WinMessages.nsh
!insertmacro GetRoot
!insertmacro un.GetRoot
@@ -127,6 +128,21 @@ Function ShowExpert
IfFileExists $d\win32-loader.ini +3 0
MessageBox MB_OK|MB_ICONSTOP "$(error_missing_ini)"
Quit
+
+; ********************************************** Display README.html if found
+ ReadINIStr $0 $PLUGINSDIR\maps.ini "languages" "$LANGUAGE"
+ IfFileExists $d\README.$0.html 0 +3
+ StrCpy $0 README.$0.html
+ Goto readme_file_found
+ IfFileExists $d\README.html 0 readme_file_not_found
+ StrCpy $0 README.html
+ Goto readme_file_found
+
+readme_file_found:
+ ShowWindow $HWNDPARENT ${SW_MINIMIZE}
+ ExecShell "open" "file://$d/$0"
+
+readme_file_not_found:
!endif
; ********************************************** Initialise $arch