summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorRobert Millan <rmh@debian.org>2007-07-17 15:30:42 +0000
committerRobert Millan <rmh@debian.org>2007-07-17 15:30:42 +0000
commit5d38f1eabd0d87f89ba4bdc5fec8d80033832ee1 (patch)
treea1e4e4bfb9e5a24acae6dfe74e0e01f985c10e3d /Makefile
parent3fb857dbd7362c894ba3cb82287fba58c5fe1ce3 (diff)
Write a smarter parser for bcdedit.exe output. This fixes bootmgr hooking for non-English versions of Vista.
r48415
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index afaf84e..cfe65b0 100644
--- a/Makefile
+++ b/Makefile
@@ -13,7 +13,8 @@ all: win32-loader.exe
win32-loader.exe: main.nsi checkspacefree.nsh maps.ini \
templates/expert.ini templates/graphics.ini templates/custom.ini templates/warning.ini \
- plugins/cpuid/test64.dll plugins/systeminfo/systeminfo.dll swirl.ico license \
+ plugins/cpuid/test64.dll plugins/systeminfo/systeminfo.dll plugins/string.dll \
+ swirl.ico license \
contrib/wget.exe
$(MAKE) -C l10n
$(MAKENSIS) main.nsi
@@ -34,6 +35,10 @@ plugins/systeminfo/systeminfo.dll: plugins/systeminfo/systeminfo.c
$(CC) -Wl,--file-alignment,512 $^ -shared -o $@
$(STRIP) $@
+plugins/string.dll: plugins/string.c
+ $(CC) -Wl,--file-alignment,512 $^ -shared -o $@
+ $(STRIP) $@
+
maps.ini: maps.ini.in /usr/share/iso-codes/iso_3166.tab
cp maps.ini.in maps.ini
echo -en "\n[countries]\n" >> maps.ini
@@ -70,7 +75,7 @@ netboot/install.amd/gtk/initrd.gz:
clean:
$(MAKE) -C l10n clean
- rm -f plugins/cpuid/*.dll plugins/cpuid/*.exe plugins/systeminfo/*.dll win32-loader.exe win32-loader.iso *~ */*~ maps.ini license
+ rm -f plugins/cpuid/*.dll plugins/cpuid/*.exe plugins/systeminfo/*.dll plugins/*.dll win32-loader.exe win32-loader.iso *~ */*~ maps.ini license
distclean: clean
rm -f debian/compat