summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonas Bernoulli <jonas@bernoul.li>2020-01-02 22:38:51 +0100
committerJonas Bernoulli <jonas@bernoul.li>2020-01-02 22:46:45 +0100
commitd3150a51fe48e310892b1ad4fc227b00eb278c31 (patch)
treeea21b2bd820fee6888b017d4e52f6a32c91e6013
parent324285fc1e43a7d299b06eef166475064445242b (diff)
make: Copy indices for htmlified info manuals
-rw-r--r--Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 5dda1ce..a0af182 100644
--- a/Makefile
+++ b/Makefile
@@ -135,6 +135,8 @@ release: html html-dir pdf
@aws s3 cp $(PKG).html $(RELEASE_TARGET)
@aws s3 cp $(PKG).pdf $(RELEASE_TARGET)
@aws s3 sync --delete $(PKG) $(RELEASE_TARGET)$(PKG)/
+ @aws s3 cp $(PUBLISH_TARGET)dir.html $(RELEASE_TARGET)dir.html
+ @aws s3 cp $(PUBLISH_TARGET)dir/index.html $(RELEASE_TARGET)dir/index.html
@printf "Generating CDN invalidation\n"
@aws cloudfront create-invalidation --distribution-id $(CFRONT_DIST) --paths \
"$(subst $(space),$(comma),$(addprefix $(RELEASE_PATH),$(CFRONT_PATHS)))" > /dev/null