summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorJonas Bernoulli <jonas@bernoul.li>2018-03-22 22:50:54 +0100
committerJonas Bernoulli <jonas@bernoul.li>2018-03-22 22:50:54 +0100
commit22a581d4b32d8eb3d9647c13bc30900cde3ae191 (patch)
tree97bb0d96c3ded9048eea3062430e3684ed19f173 /Makefile
parentbc184cf02bf78078adce79a16ffb4fccab421cd1 (diff)
make: Remove deleted pages when publishing manual
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 602c58c..dd4b8be 100644
--- a/Makefile
+++ b/Makefile
@@ -118,12 +118,12 @@ PREVIEW_TARGET ?= $(PREVIEW_BUCKET)$(PUBLISH_PATH)
preview: html html-dir pdf
@aws s3 cp $(PKG).html $(PREVIEW_TARGET)
@aws s3 cp $(PKG).pdf $(PREVIEW_TARGET)
- @aws s3 sync $(PKG) $(PREVIEW_TARGET)$(PKG)/
+ @aws s3 sync --delete $(PKG) $(PREVIEW_TARGET)$(PKG)/
publish: html html-dir pdf
@aws s3 cp $(PKG).html $(PUBLISH_TARGET)
@aws s3 cp $(PKG).pdf $(PUBLISH_TARGET)
- @aws s3 sync $(PKG) $(PUBLISH_TARGET)$(PKG)/
+ @aws s3 sync --delete $(PKG) $(PUBLISH_TARGET)$(PKG)/
@printf "Generating CDN invalidation\n"
@aws cloudfront create-invalidation \
--distribution-id $(CFRONT_DIST) --paths "\