summaryrefslogtreecommitdiff
path: root/alternative_wmiircs/ruby
diff options
context:
space:
mode:
authorAndrew Shadura <bugzilla@tut.by>2012-08-10 17:28:37 +0200
committerAndrew Shadura <bugzilla@tut.by>2012-08-10 17:28:37 +0200
commit73a0b1b034b50c3356b51e389daa8bfd5f113853 (patch)
tree89f259da840cdf6a7aad11b983942e7926c70d59 /alternative_wmiircs/ruby
parent79e6dfc63311b132887889a6f4f582480575e80a (diff)
Synchronise to the latest hg tip.
Diffstat (limited to 'alternative_wmiircs/ruby')
-rw-r--r--alternative_wmiircs/ruby/Makefile2
-rw-r--r--alternative_wmiircs/ruby/README23
2 files changed, 12 insertions, 13 deletions
diff --git a/alternative_wmiircs/ruby/Makefile b/alternative_wmiircs/ruby/Makefile
index 5d8fd65..353f5c1 100644
--- a/alternative_wmiircs/ruby/Makefile
+++ b/alternative_wmiircs/ruby/Makefile
@@ -9,5 +9,5 @@ EXECS = wmiirc
TEXT = config.rb \
config.yaml
-DIR = $(ETC)/wmii$(CONFVERSION)/ruby
+DIR = $(GLOBALCONF)/ruby
DOCDIR = $(DOC)/alternative_wmiircs/ruby
diff --git a/alternative_wmiircs/ruby/README b/alternative_wmiircs/ruby/README
index 788e0b4..894c0cb 100644
--- a/alternative_wmiircs/ruby/README
+++ b/alternative_wmiircs/ruby/README
@@ -8,10 +8,9 @@ string interpolation in key bindings, as should be apparent in
the included config.yaml.
In particular, not that there is no need to copy any files to
-~/.wmii-hg or ~/.wmii other than config.yaml. The script will
-happily load the requisite files from their default install
-location. They can be loaded either by involing wmii as
-follows:
+@LOCALCONF@ other than config.yaml. The script will happily load
+the requisite files from their default install location. They
+can be loaded either by involing wmii as follows:
wmiir -r ruby/wmiirc
@@ -51,11 +50,11 @@ Installation:
gem install librmpd # optional
# install
- mv ~/.wmii-hg ~/.wmii-hg.backup
- git clone git://github.com/sunaku/wmiirc.git ~/.wmii-hg
+ mv @LOCALCONF@ @LOCALCONF@.backup
+ git clone git://github.com/sunaku/wmiirc.git @LOCALCONF@
# choose
- cd ~/.wmii-hg
+ cd @LOCALCONF@
git checkout --track -b CHOICE origin/CHOICE # choices are:
+--------+------------------------------------------------+
@@ -68,21 +67,21 @@ Installation:
+--------+------------------------------------------------+
# run
- ~/.wmii-hg/wmiirc
+ @LOCALCONF@/wmiirc
Documentation:
# see list of all key bindings
- egrep '^ +\$\{\w+\}' ~/.wmii-hg/config.yaml
+ egrep '^ +\$\{\w+\}' @LOCALCONF@/config.yaml
# read the configuration file
- less ~/.wmii-hg/config.yaml
+ less @LOCALCONF@/config.yaml
Configuration:
- Edit ~/.wmii-hg/config.yaml to your liking.
+ Edit @LOCALCONF@/config.yaml to your liking.
- Run ~/.wmii-hg/wmiirc to apply your changes.
+ Run @LOCALCONF@/wmiirc to apply your changes.
Contribution: