summaryrefslogtreecommitdiff
path: root/config.mk
diff options
context:
space:
mode:
authorAndrew Shadura <bugzilla@tut.by>2012-08-10 17:28:37 +0200
committerAndrew Shadura <bugzilla@tut.by>2012-08-10 17:28:37 +0200
commit73a0b1b034b50c3356b51e389daa8bfd5f113853 (patch)
tree89f259da840cdf6a7aad11b983942e7926c70d59 /config.mk
parent79e6dfc63311b132887889a6f4f582480575e80a (diff)
Synchronise to the latest hg tip.
Diffstat (limited to 'config.mk')
-rw-r--r--config.mk28
1 files changed, 17 insertions, 11 deletions
diff --git a/config.mk b/config.mk
index 7b47cc8..0512ce7 100644
--- a/config.mk
+++ b/config.mk
@@ -8,6 +8,7 @@ PREFIX = /usr/local
ETC = $(PREFIX)/etc
LIBDIR = $(PREFIX)/lib
INCLUDE = $(PREFIX)/include
+ PYPREFIX = --prefix=$(PREFIX)
# Includes and libs
INCLUDES = -I. -I$(ROOT)/include -I$(INCLUDE) -I/usr/include
@@ -17,11 +18,8 @@ TERMINAL = xterm
# Flags
include $(ROOT)/mk/gcc.mk
-CFLAGS += -Os # $(DEBUGCFLAGS) -O0
-LDFLAGS += # -g $(LIBS)
-SOLDFLAGS += $(LDFLAGS)
-SHARED = -shared -Wl,-soname=$(SONAME)
-STATIC = -static
+CFLAGS += -Os $(DEBUGCFLAGS)
+LDFLAGS += -g
# Compiler, Linker. Linker should usually *not* be ld.
CC = cc -c
@@ -29,10 +27,19 @@ LD = cc
# Archiver
AR = ar crs
-X11PACKAGES = xft
+PYTHON = python
+
+X11PACKAGES = x11 xinerama xrender xrandr
INCX11 = $$(pkg-config --cflags $(X11PACKAGES))
-LIBICONV = # Leave blank if your libc includes iconv (glibc does)
-LIBIXP = $(ROOT)/lib/libixp.a
+LIBIXP = $(LIBDIR)/libixp.a
+
+# Enable RTLD. Only necessary for Xft support.
+CFLAGS += -DHAVE_RTLD
+LDFLAGS += -ldl # Comment this out on BSD systems.
+
+SOLDFLAGS += $(LDFLAGS)
+SHARED = -shared -Wl,-soname=$(SONAME)
+STATIC = -static
# Your make shell. By default, the first found of /bin/dash, /bin/ksh,
# /bin/sh. Except with bsdmake, which assumes /bin/sh is sane. bash and zsh
@@ -49,14 +56,13 @@ LIBIXP = $(ROOT)/lib/libixp.a
#CC=pcc -c
#LD=pcc
-# *BSD
-#LIBICONV = -L/usr/local/lib -liconv
-# +Darwin
+# Darwin
#STATIC = # Darwin doesn't like static linking
#SHARED = -dynamiclib
#SOEXT = dylib
# Solaris
+#SHELL = /bin/bash
#CFLAGS = -fast $(INCS)
#LDFLAGS = $(LIBS) -R$(PREFIX)/lib -lsocket -lnsl
#CFLAGS += -xtarget=ultra