summaryrefslogtreecommitdiff
path: root/config.mk
diff options
context:
space:
mode:
authorAndrew Shadura <andrewsh@debian.org>2016-04-29 15:52:16 +0200
committerAndrew Shadura <andrewsh@debian.org>2016-04-29 15:52:16 +0200
commitc6dd1ec3b3d71a979f106879669a15d94cfed6ef (patch)
tree9fbade96d39c5df18899e04889915ee3180d3c9d /config.mk
parentcc0dafee5f33f4efc97b31ebb64f9a3459c0873b (diff)
Apply patches for dgit.debian/3.10_20120413+hg2813-9
Diffstat (limited to 'config.mk')
-rw-r--r--config.mk6
1 files changed, 2 insertions, 4 deletions
diff --git a/config.mk b/config.mk
index 0512ce7..4c62802 100644
--- a/config.mk
+++ b/config.mk
@@ -14,11 +14,10 @@ PREFIX = /usr/local
INCLUDES = -I. -I$(ROOT)/include -I$(INCLUDE) -I/usr/include
LIBS = -L$(ROOT)/lib -L/usr/lib
-TERMINAL = xterm
+TERMINAL = x-terminal-emulator
# Flags
include $(ROOT)/mk/gcc.mk
-CFLAGS += -Os $(DEBUGCFLAGS)
LDFLAGS += -g
# Compiler, Linker. Linker should usually *not* be ld.
@@ -30,8 +29,7 @@ AR = ar crs
PYTHON = python
X11PACKAGES = x11 xinerama xrender xrandr
-INCX11 = $$(pkg-config --cflags $(X11PACKAGES))
-LIBIXP = $(LIBDIR)/libixp.a
+LIBIXP = -lixp
# Enable RTLD. Only necessary for Xft support.
CFLAGS += -DHAVE_RTLD