summaryrefslogtreecommitdiff
path: root/mk/gcc.mk
diff options
context:
space:
mode:
Diffstat (limited to 'mk/gcc.mk')
-rw-r--r--mk/gcc.mk28
1 files changed, 28 insertions, 0 deletions
diff --git a/mk/gcc.mk b/mk/gcc.mk
new file mode 100644
index 0000000..b37b59c
--- /dev/null
+++ b/mk/gcc.mk
@@ -0,0 +1,28 @@
+DEBUGCFLAGS = \
+ -g \
+ -O1 \
+ -fno-builtin \
+ -fno-inline \
+ -fno-omit-frame-pointer \
+ -fno-optimize-sibling-calls \
+ -fno-unroll-loops
+CFLAGS += \
+ -std=c99 \
+ -pedantic \
+ -pipe \
+ -fno-strict-aliasing \
+ -Wall \
+ -Wimplicit \
+ -Wmissing-prototypes \
+ -Wno-comment \
+ -Wno-missing-braces \
+ -Wno-parentheses \
+ -Wno-sign-compare \
+ -Wno-switch \
+ -Wpointer-arith \
+ -Wreturn-type \
+ -Wstrict-prototypes \
+ -Wtrigraphs
+MKDEP = cpp -M
+SOCFLAGS += -fPIC
+