summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBastian Blank <waldi@debian.org>2014-07-05 11:47:01 +0200
committerHans van Kranenburg <hans.van.kranenburg@mendix.com>2019-06-18 09:50:22 +0200
commit882029074a640f7326fb1b9d55e3153271b7cdc5 (patch)
tree1a0587f4cef79e00288aa095a52862523590172b
parentfb7a55c6127598038d59b7884e826a79e0d09f13 (diff)
pygrub: Set sys.path
We install libfsimage in a non-standard path for Reasons. (See debian/rules.) This patch was originally part of `tools-pygrub-prefix.diff' (eg commit 51657319be54) and included changes to the Makefile to change the installation arrangements (we do that part in the rules now since that is a lot less prone to conflicts when we update) and to shared library rpath (which is now done in a separate patch). (Commit message rewritten by Ian Jackson.) Signed-off-by: Ian Jackson <ian.jackson@citrix.com> squash! pygrub: Set sys.path and rpath
-rwxr-xr-xtools/pygrub/src/pygrub2
1 files changed, 2 insertions, 0 deletions
diff --git a/tools/pygrub/src/pygrub b/tools/pygrub/src/pygrub
index 097787974b..f8d510370a 100755
--- a/tools/pygrub/src/pygrub
+++ b/tools/pygrub/src/pygrub
@@ -20,6 +20,8 @@ import platform
import curses, _curses, curses.wrapper, curses.textpad, curses.ascii
import getopt
+sys.path.insert(1, sys.path[0] + '/../lib/python')
+
import fsimage
import grub.GrubConf
import grub.LiloConf