summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rwxr-xr-xbdfnorm7
-rw-r--r--debian/changelog3
2 files changed, 8 insertions, 2 deletions
diff --git a/bdfnorm b/bdfnorm
index 0b02834..bbca464 100755
--- a/bdfnorm
+++ b/bdfnorm
@@ -1,5 +1,12 @@
#!/usr/bin/perl -w
+# BDF can represent glyphs as smaller bitmap rectangles with padding.
+# But our approach to font editing works best if the glyphs are the
+# full character cell. Although most fonts do not use this feature
+# (at least, as seen in pdf2bdf output), some do, and also output from
+# fontforge does. So this script pads each glyph to the font bounding
+# box.
+
use strict;
use POSIX;
diff --git a/debian/changelog b/debian/changelog
index 62d3f87..18561d5 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -15,8 +15,7 @@ xfonts-traditional (1.7.2~~iwj) UNRELEASED; urgency=medium
* An internal error message in printrule is improved slightly.
* Add debhelper-build-stamp to .gitignore.
* Permit new foundry names to contain "."s.
- * Add bdf normaliser (to cope with fontforge output directly, since
- bdftopcf | pcf2bdf sometimes fails).
+ * Add bdf normaliser.
-- Ian Jackson <ijackson@chiark.greenend.org.uk> Mon, 25 Apr 2016 02:23:06 +0100