summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephane Glondu <steph@glondu.net>2023-08-09 13:08:52 +0200
committerStephane Glondu <steph@glondu.net>2023-08-09 13:40:05 +0200
commit4f0ddfc5fd09715705ff537221a3f29f6a84dfec (patch)
tree68b284ba7af30632abbb6e20be0f26a57bf2d47e
parent6b994f6fcfce1704ac91cedcff77dc9a8d33dc0b (diff)
Update packaging
-rw-r--r--debian/compat1
-rw-r--r--debian/control10
-rw-r--r--debian/libxmlrpc-light-ocaml-dev.install.in (renamed from debian/libxmlrpc-light-ocaml-dev.dirs.in)0
-rwxr-xr-xdebian/rules43
4 files changed, 21 insertions, 33 deletions
diff --git a/debian/compat b/debian/compat
deleted file mode 100644
index f599e28..0000000
--- a/debian/compat
+++ /dev/null
@@ -1 +0,0 @@
-10
diff --git a/debian/control b/debian/control
index e1ab0ad..dd636ea 100644
--- a/debian/control
+++ b/debian/control
@@ -6,15 +6,17 @@ Uploaders:
Pietro Abate <pietro.abate@pps.jussieu.fr>,
Mehdi Dogguy <mehdi@debian.org>
Build-Depends:
- cdbs,
- debhelper (>= 10~),
- ocaml-nox,
+ debhelper-compat (= 13),
+ ocaml,
libocamlnet-ocaml-dev,
libxml-light-ocaml-dev,
libnethttpd-ocaml-dev,
ocaml-findlib,
+ libfindlib-ocaml-dev,
+ libounit-ocaml-dev,
dh-ocaml
-Standards-Version: 3.9.2
+Standards-Version: 4.6.2
+Rules-Requires-Root: no
Vcs-Git: https://salsa.debian.org/ocaml-team/xmlrpc-light.git
Vcs-Browser: https://salsa.debian.org/ocaml-team/xmlrpc-light
diff --git a/debian/libxmlrpc-light-ocaml-dev.dirs.in b/debian/libxmlrpc-light-ocaml-dev.install.in
index 702950d..702950d 100644
--- a/debian/libxmlrpc-light-ocaml-dev.dirs.in
+++ b/debian/libxmlrpc-light-ocaml-dev.install.in
diff --git a/debian/rules b/debian/rules
index a1243d0..e224016 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,30 +1,9 @@
#!/usr/bin/make -f
-# debian/rules for xmlrpc-light package
-# Adapted from debian/rules for xml-light package by Pietro Abate
-# Copyright (C) 2006 Sylvain Le Gall <gildor@debian.org>
-# Copyright (C) 2007 Sylvain Le Gall <gildor@debian.org>
-#
-# This program is free software; you can redistribute it and/or
-# modify it under the terms of the GNU General Public License as
-# published by the Free Software Foundation; either version 2, or (at
-# your option) any later version.
-#
-# This program is distributed in the hope that it will be useful, but
-# WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
-# General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License
-# along with this program; if not, write to the Free Software
-# Foundation, Inc., 51 Franklin St, Fifth Floor, Boston,
-# MA 02110-1301, USA.
-
-include /usr/share/cdbs/1/rules/debhelper.mk
-include /usr/share/cdbs/1/class/makefile.mk
-include /usr/share/cdbs/1/rules/ocaml.mk
-
-PACKAGE_DEV := libxmlrpc-light-ocaml-dev
-DESTDIR_DEV := $(CURDIR)/debian/$(PACKAGE_DEV)
+
+include /usr/share/ocaml/ocamlvars.mk
+
+DESTDIR := $(CURDIR)/debian/tmp
+INSTALLDIR := $(DESTDIR)$(OCAML_STDLIB_DIR)/xmlrpc-light
DEB_MAKE_CLEAN_TARGET := clean
@@ -37,6 +16,14 @@ DEB_MAKE_INSTALL_TARGET := install
ifeq ($(OCAML_HAVE_OCAMLOPT),yes)
DEB_MAKE_INSTALL_TARGET += installopt
endif
-DEB_MAKE_INSTALL_TARGET += INSTALLDIR="$(DESTDIR_DEV)/$(OCAML_STDLIB_DIR)/xmlrpc-light"
+DEB_MAKE_INSTALL_TARGET += INSTALLDIR="$(INSTALLDIR)"
+
+%:
+ dh $@ --with ocaml
+
+override_dh_auto_build:
+ $(MAKE) $(DEB_MAKE_BUILD_TARGET)
-CDBS_BUILD_DEPENDS := $(subst ocaml-nox,ocaml-nox (>= 3.10.0-8),$(CDBS_BUILD_DEPENDS))
+override_dh_auto_install:
+ mkdir -p $(INSTALLDIR)
+ $(MAKE) $(DEB_MAKE_INSTALL_TARGET)