summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRylie Pavlik <rylie.pavlik@collabora.com>2024-03-11 17:32:42 -0500
committerRylie Pavlik <rylie.pavlik@collabora.com>2024-03-11 17:32:42 -0500
commit72f9992f5aebd77ae510cbd1602f37df1d55995c (patch)
treee85e5d29890058aab2f60db6d2de4e2afab27e47
parent96e7b7f44a951b40fb738c5cb622b7d0d2bbac2d (diff)
New upstream version 1.1.1
-rw-r--r--.gitignore4
-rw-r--r--.gitlab-ci.yml34
-rw-r--r--.mailmap9
-rw-r--r--.reuse/dep52
-rw-r--r--70-xrhardware-hwdb.rules2
-rw-r--r--70-xrhardware.hwdb45
-rw-r--r--70-xrhardware.rules45
-rw-r--r--CHANGELOG.md21
-rw-r--r--Makefile3
-rw-r--r--changes/.proclamation.json2
-rw-r--r--changes/README.md2
-rwxr-xr-xmake-hwdb-file.py5
-rwxr-xr-xmake-hwdb-rules-file.py6
-rwxr-xr-xmake-udev-rules.py5
-rwxr-xr-xtest-db.py6
-rw-r--r--xrhardware/__init__.py3
-rw-r--r--xrhardware/db.py23
-rw-r--r--xrhardware/device.py5
-rw-r--r--xrhardware/generate.py7
19 files changed, 185 insertions, 44 deletions
diff --git a/.gitignore b/.gitignore
index 8ed0f21..44911ba 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,5 +1,5 @@
# SPDX-License-Identifier: CC0-1.0
-# SPDX-FileCopyrightText: 2019-2021, Collabora, Ltd. and the xr-hardware contributors
+# SPDX-FileCopyrightText: 2019-2024, Collabora, Ltd. and the xr-hardware contributors
__pycache__/
.*
@@ -8,4 +8,6 @@ __pycache__/
!.markdownlint.yaml
!.reuse
!.flake8
+!.mailmap
venv/
+container-build-report.xml
diff --git a/.gitlab-ci.yml b/.gitlab-ci.yml
index c243e9a..1b62c2d 100644
--- a/.gitlab-ci.yml
+++ b/.gitlab-ci.yml
@@ -1,30 +1,36 @@
-# Copyright 2020-2022, Collabora, Ltd
+# Copyright 2020-2024, Collabora, Ltd
# SPDX-License-Identifier: BSL-1.0
-# Author: Ryan Pavlik <ryan.pavlik@collabora.com>
-variables:
- FDO_UPSTREAM_REPO: monado/utilities/xr-hardware
+#
+# Author: Rylie Pavlik <rylie.pavlik@collabora.com>
+# Author: Simon Zeni <simon.zeni@collabora.com>
-.templates_sha: &templates_sha d5aa3941aa03c2f716595116354fb81eb8012acb
+workflow:
+ rules:
+ - if: $CI_PIPELINE_SOURCE == 'merge_request_event'
+ - if: $CI_PIPELINE_SOURCE == 'push'
include:
- project: "freedesktop/ci-templates"
- ref: *templates_sha
+ ref: 185ede0e9b9b1924b92306ab8b882a6294e92613
file: "/templates/debian.yml"
stages:
- container_prep
- test
-.xrhardware.debian:
+variables:
+ FDO_UPSTREAM_REPO: "monado/utilities/xr-hardware"
+
+.xrhardware.debian:bookworm:
variables:
- FDO_DISTRIBUTION_TAG: 2022-09-19.1
- FDO_DISTRIBUTION_VERSION: bullseye
+ FDO_DISTRIBUTION_VERSION: "bookworm"
+ FDO_DISTRIBUTION_TAG: "2024-02-28"
-debian:container_prep:
+debian:bookworm:container_prep:
+ stage: container_prep
extends:
- .fdo.container-build@debian
- - .xrhardware.debian
- stage: container_prep
+ - .xrhardware.debian:bookworm
variables:
FDO_DISTRIBUTION_PACKAGES: "python3 python3-attr python3-flake8 git make black"
@@ -32,7 +38,7 @@ test-db-and-generated:
stage: test
extends:
- .fdo.distribution-image@debian
- - .xrhardware.debian
+ - .xrhardware.debian:bookworm
script:
- make test
- make lint
@@ -43,6 +49,8 @@ test-db-and-generated:
reuse:
stage: test
+ variables:
+ GIT_STRATEGY: clone
image:
name: fsfe/reuse:latest
entrypoint: [""]
diff --git a/.mailmap b/.mailmap
new file mode 100644
index 0000000..59cc93b
--- /dev/null
+++ b/.mailmap
@@ -0,0 +1,9 @@
+# SPDX-FileCopyrightText: 2024, Collabora, Ltd. and the xr-hardware contributors
+# SPDX-License-Identifier: CC0-1.0
+
+Jakob Bornecrantz <wallbraker@gmail.com>
+Jakob Bornecrantz <wallbraker@gmail.com> <jakob@collabora.com>
+Jan Schmidt <thaytan@noraisin.net>
+Jan Schmidt <thaytan@noraisin.net> <jan@centricular.com>
+Rylie Pavlik <rylie.pavlik@collabora.com>
+Rylie Pavlik <rylie.pavlik@collabora.com> <ryan.pavlik@collabora.com>
diff --git a/.reuse/dep5 b/.reuse/dep5
index 3b29250..8ec3872 100644
--- a/.reuse/dep5
+++ b/.reuse/dep5
@@ -1,6 +1,6 @@
Format: https://www.debian.org/doc/packaging-manuals/copyright-format/1.0/
Upstream-Name: xr-hardware
-Upstream-Contact: Ryan Pavlik <ryan.pavlik@collabora.com>
+Upstream-Contact: Rylie Pavlik <rylie.pavlik@collabora.com>
Source: https://gitlab.freedesktop.org/monado/utilities/xr-hardware
Files: changes/additions/*.md
diff --git a/70-xrhardware-hwdb.rules b/70-xrhardware-hwdb.rules
index 835faaf..6653378 100644
--- a/70-xrhardware-hwdb.rules
+++ b/70-xrhardware-hwdb.rules
@@ -1,6 +1,6 @@
# Do not edit this file - generated by make-hwdb-rules-file.py
#
-# Copyright 2019-2022, Collabora, Ltd. and the xr-hardware contributors
+# Copyright 2019-2024, Collabora, Ltd. and the xr-hardware contributors
#
# SPDX-License-Identifier: BSL-1.0
diff --git a/70-xrhardware.hwdb b/70-xrhardware.hwdb
index 4361596..54411c9 100644
--- a/70-xrhardware.hwdb
+++ b/70-xrhardware.hwdb
@@ -1,6 +1,6 @@
# Do not edit this file - generated by make-hwdb-file.py
#
-# Copyright 2019-2022, Collabora, Ltd. and the xr-hardware contributors
+# Copyright 2019-2024, Collabora, Ltd. and the xr-hardware contributors
#
# SPDX-License-Identifier: BSL-1.0
@@ -133,6 +133,15 @@ usb:v054cp0c5e*
bluetooth:v054cp0c5e*
ID_xrhardware=1
+# Sony PlayStation VR2
+usb:v054cp0cde*
+ ID_xrhardware=1
+
+# Sony PlayStation VR2 Sensor Controller
+usb:v054cp0e46*
+bluetooth:v054cp0e46*
+ ID_xrhardware=1
+
# LG 360 VR R-100
usb:v1004p6374*
ID_xrhardware=1
@@ -156,6 +165,10 @@ bluetooth:v045ep066a*
usb:v045ep0659*
ID_xrhardware=1
+# Samsung Odyssey sensors
+usb:v04e8p7310*
+ ID_xrhardware=1
+
# Samsung Odyssey+ sensors
usb:v04e8p7312*
ID_xrhardware=1
@@ -176,10 +189,18 @@ usb:v03f0p0580*
usb:v17efpb801*
ID_xrhardware=1
-# Cypress Semiconductor Corp. Lenovo Explorer
+# Cypress Semiconductor Corp. (Various WMR)
usb:v04b4p6504*
ID_xrhardware=1
+# Acer AH100 QHMD
+usb:v0502pb0d6*
+ ID_xrhardware=1
+
+# Dell Visor VR118
+usb:v413cpb0d5*
+ ID_xrhardware=1
+
# Medion Erazer X1000
usb:v0408pb5d5*
ID_xrhardware=1
@@ -187,3 +208,23 @@ usb:v0408pb5d5*
# Vis3r NxtVR
usb:v1209p9d0f*
ID_xrhardware=1
+
+# Xreal Light Microcontroller
+usb:v0486p573c*
+ ID_xrhardware=1
+
+# Xreal Light OV580
+usb:v05a9p0680*
+ ID_xrhardware=1
+
+# Xreal Air
+usb:v3318p0424*
+ ID_xrhardware=1
+
+# Xreal Air 2
+usb:v3318p0428*
+ ID_xrhardware=1
+
+# Xreal Air 2 Pro
+usb:v3318p0432*
+ ID_xrhardware=1
diff --git a/70-xrhardware.rules b/70-xrhardware.rules
index 2be151c..bdb82a8 100644
--- a/70-xrhardware.rules
+++ b/70-xrhardware.rules
@@ -1,6 +1,6 @@
# Do not edit this file - generated by make-udev-rules.py
#
-# Copyright 2019-2022, Collabora, Ltd. and the xr-hardware contributors
+# Copyright 2019-2024, Collabora, Ltd. and the xr-hardware contributors
#
# SPDX-License-Identifier: BSL-1.0
@@ -140,6 +140,15 @@ ATTRS{idVendor}=="054c", ATTRS{idProduct}=="0c5e", TAG+="uaccess", ENV{ID_xrhard
KERNELS=="0005:054C:0C5E.*", TAG+="uaccess", ENV{ID_xrhardware}="1"
+# Sony PlayStation VR2 - USB
+ATTRS{idVendor}=="054c", ATTRS{idProduct}=="0cde", TAG+="uaccess", ENV{ID_xrhardware}="1"
+
+
+# Sony PlayStation VR2 Sensor Controller - Bluetooth, USB
+ATTRS{idVendor}=="054c", ATTRS{idProduct}=="0e46", TAG+="uaccess", ENV{ID_xrhardware}="1"
+KERNELS=="0005:054C:0E46.*", TAG+="uaccess", ENV{ID_xrhardware}="1"
+
+
# LG 360 VR R-100 - USB
ATTRS{idVendor}=="1004", ATTRS{idProduct}=="6374", TAG+="uaccess", ENV{ID_xrhardware}="1"
@@ -160,6 +169,10 @@ KERNELS=="0005:045E:066A.*", TAG+="uaccess", ENV{ID_xrhardware}="1", ENV{LIBINPU
ATTRS{idVendor}=="045e", ATTRS{idProduct}=="0659", TAG+="uaccess", ENV{ID_xrhardware}="1"
+# Samsung Odyssey sensors - USB
+ATTRS{idVendor}=="04e8", ATTRS{idProduct}=="7310", TAG+="uaccess", ENV{ID_xrhardware}="1"
+
+
# Samsung Odyssey+ sensors - USB
ATTRS{idVendor}=="04e8", ATTRS{idProduct}=="7312", TAG+="uaccess", ENV{ID_xrhardware}="1"
@@ -180,10 +193,18 @@ ATTRS{idVendor}=="03f0", ATTRS{idProduct}=="0580", TAG+="uaccess", ENV{ID_xrhard
ATTRS{idVendor}=="17ef", ATTRS{idProduct}=="b801", TAG+="uaccess", ENV{ID_xrhardware}="1"
-# Cypress Semiconductor Corp. Lenovo Explorer - USB
+# Cypress Semiconductor Corp. (Various WMR) - USB
ATTRS{idVendor}=="04b4", ATTRS{idProduct}=="6504", TAG+="uaccess", ENV{ID_xrhardware}="1"
+# Acer AH100 QHMD - USB
+ATTRS{idVendor}=="0502", ATTRS{idProduct}=="b0d6", TAG+="uaccess", ENV{ID_xrhardware}="1"
+
+
+# Dell Visor VR118 - USB
+ATTRS{idVendor}=="413c", ATTRS{idProduct}=="b0d5", TAG+="uaccess", ENV{ID_xrhardware}="1"
+
+
# Medion Erazer X1000 - USB
ATTRS{idVendor}=="0408", ATTRS{idProduct}=="b5d5", TAG+="uaccess", ENV{ID_xrhardware}="1"
@@ -191,6 +212,26 @@ ATTRS{idVendor}=="0408", ATTRS{idProduct}=="b5d5", TAG+="uaccess", ENV{ID_xrhard
# Vis3r NxtVR - USB
ATTRS{idVendor}=="1209", ATTRS{idProduct}=="9d0f", TAG+="uaccess", ENV{ID_xrhardware}="1"
+
+# Xreal Light Microcontroller - USB
+ATTRS{idVendor}=="0486", ATTRS{idProduct}=="573c", TAG+="uaccess", ENV{ID_xrhardware}="1"
+
+
+# Xreal Light OV580 - USB
+ATTRS{idVendor}=="05a9", ATTRS{idProduct}=="0680", TAG+="uaccess", ENV{ID_xrhardware}="1"
+
+
+# Xreal Air - USB
+ATTRS{idVendor}=="3318", ATTRS{idProduct}=="0424", TAG+="uaccess", ENV{ID_xrhardware}="1"
+
+
+# Xreal Air 2 - USB
+ATTRS{idVendor}=="3318", ATTRS{idProduct}=="0428", TAG+="uaccess", ENV{ID_xrhardware}="1"
+
+
+# Xreal Air 2 Pro - USB
+ATTRS{idVendor}=="3318", ATTRS{idProduct}=="0432", TAG+="uaccess", ENV{ID_xrhardware}="1"
+
###################
# END DEVICE LIST #
diff --git a/CHANGELOG.md b/CHANGELOG.md
index 0aa2263..8468aa1 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -2,9 +2,26 @@
<!--
SPDX-License-Identifier: CC0-1.0
-SPDX-FileCopyrightText: 2020-2022 Collabora, Ltd. and the xr-hardware contributors
+SPDX-FileCopyrightText: 2020-2024, Collabora, Ltd. and the xr-hardware contributors
-->
+## xr-hardware 1.1.1 (2024-03-11)
+
+- Additions
+ - Add Sony PSVR2 and Sense controller rules
+ ([!24](https://gitlab.freedesktop.org/monado/utilities/xr-hardware/merge_requests/24))
+ - Add Acer AH100 (WinMR) headset.
+ ([!26](https://gitlab.freedesktop.org/monado/utilities/xr-hardware/merge_requests/26))
+ - Added entries for Dell Visor.
+ ([!29](https://gitlab.freedesktop.org/monado/utilities/xr-hardware/merge_requests/29),
+ [#9](https://gitlab.freedesktop.org/monado/utilities/xr-hardware/issues/9))
+ - Adds Xreal Light, Xreal Air, Xreal Air 2, and Xreal Air 2 Pro, and renames
+ Nreal to Xreal due to the rebrand.
+ ([!31](https://gitlab.freedesktop.org/monado/utilities/xr-hardware/merge_requests/31),
+ [!25](https://gitlab.freedesktop.org/monado/utilities/xr-hardware/merge_requests/25))
+ - Add rule for original WinMR Samsung Odyssey (XE700X3AI)
+ ([!32](https://gitlab.freedesktop.org/monado/utilities/xr-hardware/merge_requests/32))
+
## xr-hardware 1.1.0 (2022-09-19)
- Additions
@@ -75,7 +92,7 @@ Note that the default branch has been renamed to "main" in the repository.
- Improvements
- Valve Index: ID for Watchman device
([!8](https://gitlab.freedesktop.org/monado/utilities/xr-hardware/merge_requests/8))
- - Now using [Proclamation](https://gitlab.com/ryanpavlik/proclamation) to
+ - Now using [Proclamation](https://gitlab.com/proclamation/proclamation) to
maintain a project changelog.
([!9](https://gitlab.freedesktop.org/monado/utilities/xr-hardware/merge_requests/9))
- NOLO CV1: Additional ID
diff --git a/Makefile b/Makefile
index 3c8d73e..3b38aae 100644
--- a/Makefile
+++ b/Makefile
@@ -1,7 +1,8 @@
#!/usr/bin/env make -f
# Copyright 2020-2022 Collabora, Ltd
# SPDX-License-Identifier: BSL-1.0
-# Author: Ryan Pavlik <ryan.pavlik@collabora.com>
+#
+# Original Author: Rylie Pavlik <rylie.pavlik@collabora.com>
RULES_FILE := 70-xrhardware.rules
HWDB_FILE := 70-xrhardware.hwdb
diff --git a/changes/.proclamation.json b/changes/.proclamation.json
index a1308d5..4bd2008 100644
--- a/changes/.proclamation.json
+++ b/changes/.proclamation.json
@@ -1,6 +1,6 @@
{
"$schema": "https://ryanpavlik.gitlab.io/proclamation/proclamation.schema.json",
- "#": "This is a config file for Proclamation, the changelog combiner: https://gitlab.com/ryanpavlik/proclamation",
+ "#": "This is a config file for Proclamation, the changelog combiner: https://gitlab.com/proclamation/proclamation",
"SPDX-License-Identifier: CC0-1.0": "",
"SPDX-FileCopyrightText: 2020 Collabora, Ltd. and the Proclamation contributors": "",
"project_name": "xr-hardware",
diff --git a/changes/README.md b/changes/README.md
index 92e471b..a916419 100644
--- a/changes/README.md
+++ b/changes/README.md
@@ -13,7 +13,7 @@ fragment for the changelog describing their change. See below for more details.
- Config file: default name (`.proclamation.json`)
- Location of the per-changelog-section directories: `changes/`
-[Proclamation]: https://gitlab.com/ryanpavlik/proclamation
+[Proclamation]: https://gitlab.com/proclamation/proclamation
## Table of Contents
diff --git a/make-hwdb-file.py b/make-hwdb-file.py
index 8d20e99..845ce68 100755
--- a/make-hwdb-file.py
+++ b/make-hwdb-file.py
@@ -1,7 +1,8 @@
#!/usr/bin/env python3
-# Copyright 2019-2022 Collabora, Ltd
+# Copyright 2019-2022, Collabora, Ltd.
# SPDX-License-Identifier: BSL-1.0
-# Author: Ryan Pavlik <ryan.pavlik@collabora.com>
+#
+# Original Author: Rylie Pavlik <rylie.pavlik@collabora.com>
"""Make a hwdb file. Requires an associated .rules file."""
from xrhardware.db import get_devices
diff --git a/make-hwdb-rules-file.py b/make-hwdb-rules-file.py
index 44bb5be..3fc9536 100755
--- a/make-hwdb-rules-file.py
+++ b/make-hwdb-rules-file.py
@@ -1,13 +1,13 @@
#!/usr/bin/env python3
-# Copyright 2019-2022 Collabora, Ltd
+# Copyright 2019-2022, Collabora, Ltd.
# SPDX-License-Identifier: BSL-1.0
-# Author: Ryan Pavlik <ryan.pavlik@collabora.com>
+#
+# Original Author: Rylie Pavlik <rylie.pavlik@collabora.com>
"""Make a .rules file for use with a hwdb file."""
from xrhardware.generate import generate_rules_file_contents
if __name__ == "__main__":
-
print(
generate_rules_file_contents(
__file__,
diff --git a/make-udev-rules.py b/make-udev-rules.py
index c6a02bb..9c5b295 100755
--- a/make-udev-rules.py
+++ b/make-udev-rules.py
@@ -1,7 +1,8 @@
#!/usr/bin/env python3
-# Copyright 2019-2022 Collabora, Ltd
+# Copyright 2019-2022, Collabora, Ltd.
# SPDX-License-Identifier: BSL-1.0
-# Author: Ryan Pavlik <ryan.pavlik@collabora.com>
+#
+# Original Author: Rylie Pavlik <rylie.pavlik@collabora.com>
"""Make a standalone .rules file."""
from xrhardware.db import get_devices
from xrhardware.generate import generate_rules_file_contents
diff --git a/test-db.py b/test-db.py
index 7d22a5a..ffd8eeb 100755
--- a/test-db.py
+++ b/test-db.py
@@ -1,7 +1,8 @@
#!/usr/bin/env python3
-# Copyright 2019-2022 Collabora, Ltd
+# Copyright 2019-2024, Collabora, Ltd.
# SPDX-License-Identifier: BSL-1.0
-# Author: Ryan Pavlik <ryan.pavlik@collabora.com>
+#
+# Original Author: Rylie Pavlik <rylie.pavlik@collabora.com>
"""XR Hardware device database consistency test."""
from xrhardware.db import get_devices
@@ -12,7 +13,6 @@ if __name__ == "__main__":
hexstring = re.compile(r"[0-9a-fA-F]{4}")
for dev in get_devices():
-
print("Checking entry for:", dev.extended_description)
# Duplicate ID?
diff --git a/xrhardware/__init__.py b/xrhardware/__init__.py
index 5c5820f..197d3f9 100644
--- a/xrhardware/__init__.py
+++ b/xrhardware/__init__.py
@@ -1,5 +1,6 @@
#!/usr/bin/env python3 -i
# Copyright 2020 Collabora, Ltd
# SPDX-License-Identifier: BSL-1.0
-# Author: Ryan Pavlik <ryan.pavlik@collabora.com>
+#
+# Original Author: Rylie Pavlik <rylie.pavlik@collabora.com>
"""XR hardware database and associated utilities."""
diff --git a/xrhardware/db.py b/xrhardware/db.py
index 84c272e..b3d2b46 100644
--- a/xrhardware/db.py
+++ b/xrhardware/db.py
@@ -1,7 +1,8 @@
#!/usr/bin/env python3 -i
-# Copyright 2019-2020 Collabora, Ltd
+# Copyright 2019-2024, Collabora, Ltd. and the xr-hardware contributors
# SPDX-License-Identifier: BSL-1.0
-# Author: Ryan Pavlik <ryan.pavlik@collabora.com>
+#
+# Original Author: Rylie Pavlik <rylie.pavlik@collabora.com>
"""XR Hardware device database."""
from .device import Device
@@ -72,6 +73,10 @@ def get_devices():
Device("Sony PlayStation Move Motion Controller CECH-ZCM2",
"054c", "0c5e", bluetooth=True, usb=True),
+ Device("Sony PlayStation VR2", "054c", "0cde"),
+ Device("Sony PlayStation VR2 Sensor Controller",
+ "054c", "0e46", bluetooth=True, usb=True),
+
#
Device("LG 360 VR R-100", "1004", "6374"),
@@ -91,16 +96,28 @@ def get_devices():
#
# Windows Mixed Reality headsets
Device("Microsoft HoloLens Sensors", "045e", "0659"),
+ Device("Samsung Odyssey sensors", "04e8", "7310"),
Device("Samsung Odyssey+ sensors", "04e8", "7312"),
Device("HP VR1000", "03f0", "0367"),
Device("HP Reverb G1", "03f0", "0c6a"),
Device("HP Reverb G2", "03f0", "0580"),
Device("Lenovo QHMD", "17ef", "b801"),
- Device("Cypress Semiconductor Corp. Lenovo Explorer", "04b4", "6504"),
+ # At least Lenovo and Dell
+ Device("Cypress Semiconductor Corp. (Various WMR)", "04b4", "6504"),
+ Device("Acer AH100 QHMD", "0502", "b0d6"),
+ Device("Dell Visor VR118", "413c", "b0d5"),
# Quanta QHMD == Medion Erazer X1000
Device("Medion Erazer X1000", "0408", "b5d5"),
#
Device("Vis3r NxtVR", "1209", "9d0f"),
+
+ #
+ # Xreal glasses
+ Device("Xreal Light Microcontroller", "0486", "573c"),
+ Device("Xreal Light OV580", "05a9", "0680"),
+ Device("Xreal Air", "3318", "0424"),
+ Device("Xreal Air 2", "3318", "0428"),
+ Device("Xreal Air 2 Pro", "3318", "0432")
)
# fmt: on
diff --git a/xrhardware/device.py b/xrhardware/device.py
index d8956c1..187a8e8 100644
--- a/xrhardware/device.py
+++ b/xrhardware/device.py
@@ -1,7 +1,8 @@
#!/usr/bin/env python3 -i
-# Copyright 2019-2021 Collabora, Ltd
+# Copyright 2019-2022, Collabora, Ltd.
# SPDX-License-Identifier: BSL-1.0
-# Author: Ryan Pavlik <ryan.pavlik@collabora.com>
+#
+# Original Author: Rylie Pavlik <rylie.pavlik@collabora.com>
"""XR Hardware device database element type."""
from typing import Dict, Optional
diff --git a/xrhardware/generate.py b/xrhardware/generate.py
index 19d36e1..f5368ce 100644
--- a/xrhardware/generate.py
+++ b/xrhardware/generate.py
@@ -1,7 +1,8 @@
#!/usr/bin/env python3
-# Copyright 2019-2022 Collabora, Ltd
+# Copyright 2019-2024, Collabora, Ltd.
# SPDX-License-Identifier: BSL-1.0
-# Author: Ryan Pavlik <ryan.pavlik@collabora.com>
+#
+# Original Author: Rylie Pavlik <rylie.pavlik@collabora.com>
"""XR Hardware generation helper code."""
# pylint: disable=E501
@@ -10,7 +11,7 @@ _SHARED_PREFIX = "\n".join(
"# Do not edit this file - generated by {script}",
"#",
"# Copyright"
- + " 2019-2022, Collabora, Ltd. and the "
+ + " 2019-2024, Collabora, Ltd. and the "
+ "xr-hardware contributors",
"#",
"# SPDX-License-" + "Identifier: BSL-1.0",