summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules22
1 files changed, 22 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..9343dbd
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,22 @@
+#!/usr/bin/make -f
+#export DH_VERBOSE = 1
+
+export PREFIX = debian/yadm/usr
+
+%:
+ dh $@
+
+override_dh_auto_build:
+
+# Remove some files installed by upstream that are installed by the
+# packaging logic in different ways.
+execute_after_dh_auto_install:
+ rm debian/yadm/usr/share/doc/yadm/CHANGES
+ rm debian/yadm/usr/share/doc/yadm/LICENSE
+ rm -r debian/yadm/usr/share/doc/yadm/contrib
+
+override_dh_installchangelogs:
+ dh_installchangelogs CHANGES
+
+# The test requires Docker, so it is disabled.
+override_dh_auto_test: