summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSiesh1oo <siesh1oo@siesh1oo.no>2014-03-11 19:39:01 +0100
committerSiesh1oo <siesh1oo@siesh1oo.no>2014-03-13 11:29:03 +0100
commit89443aadbc6a20270de024f41ae1cc79ec75a8cf (patch)
treef1027fa49eaeb55d272e243e0eb14dea52c57d6a
parenta4d72de91dc017b299d6c11d67786274f1326133 (diff)
- Makefile: resolve merge conflict.
-rw-r--r--Makefile28
1 files changed, 23 insertions, 5 deletions
diff --git a/Makefile b/Makefile
index 73051e52..8da8b4c5 100644
--- a/Makefile
+++ b/Makefile
@@ -22,11 +22,22 @@ TARGETS = yosys yosys-config
all: top-all
-CXXFLAGS = -Wall -Wextra -ggdb -I"$(shell pwd)" -MD -D_YOSYS_ -fPIC
-LDFLAGS = -rdynamic
-LDLIBS = -lstdc++ -lreadline -lm -ldl -lrt
-QMAKE = qmake-qt4
-SED = sed
+CXXFLAGS = -Wall -Wextra -ggdb -I"$(shell pwd)" -I${DESTDIR}/include -MD -D_YOSYS_ -fPIC -include kernel/posix_compatibility.h
+LDFLAGS = -I${DESTDIR}/lib
+LDLIBS = -lstdc++ -lreadline -lm -ldl
+
+ifeq (Darwin,$(findstring Darwin,$(shell uname)))
+ # add macports include and library path to search directories, don't use '-rdynamic' and '-lrt':
+ CXXFLAGS += -I/opt/local/include
+ LDFLAGS += -L/opt/local/lib
+ QMAKE = qmake
+ SED = gsed
+else
+ LDFLAGS += -rdynamic
+ LDLIBS += -lrt
+ QMAKE = qmake-qt4
+ SED = sed
+endif
YOSYS_VER := 0.2.0+
GIT_REV := $(shell git rev-parse --short HEAD || echo UNKOWN)
@@ -123,6 +134,13 @@ yosys-svgviewer: libs/svgviewer/*.h libs/svgviewer/*.cpp
cd libs/svgviewer && $(QMAKE) && make
cp libs/svgviewer/svgviewer yosys-svgviewer
+yosys-minisat: $(DESTDIR)/bin/minisat
+$(DESTDIR)/bin/minisat:
+ test -d minisat || ( git clone https://github.com/niklasso/minisat.git minisat && $(SED) -i -e 's/PRIi64/ & /' minisat/minisat/utils/Options.h )
+ ( cd minisat && git checkout $(MINISATREV) )
+ ( cd minisat && $(MAKE) prefix=$(DESTDIR) DESTDIR="" config install )
+ @( cd minisat && echo "Installed minisat version `git describe --always --dirty` into $(DESTDIR)." )
+
abc/abc-$(ABCREV):
ifneq ($(ABCREV),default)
if ( cd abc && hg identify; ) | grep -q +; then \