summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRuben Undheim <ruben.undheim@gmail.com>2015-10-07 23:58:42 +0400
committerRuben Undheim <ruben.undheim@gmail.com>2015-10-07 23:58:42 +0400
commitc6b473a9f7aab63518dade0c5445d63741c9409a (patch)
treef32e6aea6577b71990b5c88cb8e6c5f627024c79
parent4c30c5f055ecaf3a8362573c91b10f59129a40f2 (diff)
Refreshed patches
-rw-r--r--debian/patches/01_gitrevision.patch12
-rw-r--r--debian/patches/02_removeabc.patch6
-rw-r--r--debian/patches/03_notruntests.patch8
-rw-r--r--debian/patches/04_installpath.patch24
-rw-r--r--debian/patches/05_abc_executable.patch6
-rw-r--r--debian/patches/06_cflags_ldflags.patch34
6 files changed, 39 insertions, 51 deletions
diff --git a/debian/patches/01_gitrevision.patch b/debian/patches/01_gitrevision.patch
index b6e8c3cd..03f3fded 100644
--- a/debian/patches/01_gitrevision.patch
+++ b/debian/patches/01_gitrevision.patch
@@ -7,14 +7,14 @@ Forwarded: doesn't make sense upstream
Author: Ruben Undheim <ruben.undheim@gmail.com>
Index: yosys/Makefile
===================================================================
---- yosys.orig/Makefile 2015-07-24 12:08:44.116881178 +0200
-+++ yosys/Makefile 2015-07-24 12:09:23.993545416 +0200
-@@ -58,7 +58,7 @@
+--- yosys.orig/Makefile 2015-10-07 23:52:58.364134789 +0400
++++ yosys/Makefile 2015-10-07 23:53:36.182173459 +0400
+@@ -61,7 +61,7 @@
endif
- YOSYS_VER := 0.5+$(shell test -d .git && { git log --author=clifford@clifford.at --oneline c3c9fbfb8c678.. | wc -l; })
--GIT_REV := $(shell git rev-parse --short HEAD 2> /dev/null || echo UNKNOWN)
-+GIT_REV := c6ca478
+ YOSYS_VER := 0.5+$(shell cd $(YOSYS_SRC) && test -d .git && { git log --author=clifford@clifford.at --oneline c3c9fbfb8c678.. | wc -l; })
+-GIT_REV := $(shell cd $(YOSYS_SRC) && git rev-parse --short HEAD 2> /dev/null || echo UNKNOWN)
++GIT_REV := ba4cce9
OBJS = kernel/version_$(GIT_REV).o
# set 'ABCREV = default' to use abc/ as it is
diff --git a/debian/patches/02_removeabc.patch b/debian/patches/02_removeabc.patch
index 2471177a..19fcc3d2 100644
--- a/debian/patches/02_removeabc.patch
+++ b/debian/patches/02_removeabc.patch
@@ -4,9 +4,9 @@ Forwarded: doesn't make sense upstream
Author: Ruben Undheim <ruben.undheim@gmail.com>
Index: yosys/Makefile
===================================================================
---- yosys.orig/Makefile 2015-07-24 12:09:34.250841710 +0200
-+++ yosys/Makefile 2015-07-24 12:09:34.246841199 +0200
-@@ -167,7 +167,7 @@
+--- yosys.orig/Makefile 2015-10-07 23:54:26.216870697 +0400
++++ yosys/Makefile 2015-10-07 23:54:26.212870482 +0400
+@@ -174,7 +174,7 @@
ifeq ($(ENABLE_ABC),1)
CXXFLAGS += -DYOSYS_ENABLE_ABC
diff --git a/debian/patches/03_notruntests.patch b/debian/patches/03_notruntests.patch
index b6dcce56..f471c5b0 100644
--- a/debian/patches/03_notruntests.patch
+++ b/debian/patches/03_notruntests.patch
@@ -4,9 +4,9 @@ Forwarded: doesn't make sense upstream
Author: Ruben Undheim <ruben.undheim@gmail.com>
Index: yosys/Makefile
===================================================================
---- yosys.orig/Makefile 2015-07-24 12:09:53.557355218 +0200
-+++ yosys/Makefile 2015-07-24 12:09:53.553354689 +0200
-@@ -328,21 +328,21 @@
+--- yosys.orig/Makefile 2015-10-07 23:54:30.141082241 +0400
++++ yosys/Makefile 2015-10-07 23:54:30.137082026 +0400
+@@ -347,21 +347,21 @@
yosys-abc$(EXE): abc/abc-$(ABCREV)$(EXE)
$(P) cp abc/abc-$(ABCREV)$(EXE) yosys-abc$(EXE)
@@ -43,7 +43,7 @@ Index: yosys/Makefile
VALGRIND ?= valgrind --error-exitcode=1 --leak-check=full --show-reachable=yes --errors-for-leak-kinds=all
-@@ -465,6 +465,6 @@
+@@ -491,6 +491,6 @@
-include kernel/*.d
-include techlibs/*/*.d
diff --git a/debian/patches/04_installpath.patch b/debian/patches/04_installpath.patch
index 53dabf5c..85e8135d 100644
--- a/debian/patches/04_installpath.patch
+++ b/debian/patches/04_installpath.patch
@@ -4,9 +4,9 @@ Forwarded: doesn't make sense upstream
Author: Ruben Undheim <ruben.undheim@gmail.com>
Index: yosys/Makefile
===================================================================
---- yosys.orig/Makefile 2015-07-24 12:10:09.835533316 +0200
-+++ yosys/Makefile 2015-07-24 12:10:09.831532775 +0200
-@@ -17,11 +17,11 @@
+--- yosys.orig/Makefile 2015-10-07 23:54:36.805441499 +0400
++++ yosys/Makefile 2015-10-07 23:55:47.877272796 +0400
+@@ -18,11 +18,11 @@
ENABLE_GPROF := 0
ENABLE_NDEBUG := 0
@@ -21,16 +21,16 @@ Index: yosys/Makefile
EXE =
OBJS =
-@@ -36,7 +36,7 @@
- all: top-all
+@@ -39,7 +39,7 @@
+ YOSYS_SRC := $(dir $(firstword $(MAKEFILE_LIST)))
+ VPATH := $(YOSYS_SRC)
- YOSYS_SRC := $(shell pwd)
--CXXFLAGS = -Wall -Wextra -ggdb -I"$(YOSYS_SRC)" -MD -D_YOSYS_ -fPIC -I$(DESTDIR)/include
-+CXXFLAGS = -Wall -Wextra -ggdb -I"$(YOSYS_SRC)" -MD -D_YOSYS_ -fPIC -I$(DESTDIR)/usr/include
+-CXXFLAGS = -Wall -Wextra -ggdb -I. -I"$(YOSYS_SRC)" -MD -D_YOSYS_ -fPIC -I$(DESTDIR)/include
++CXXFLAGS = -Wall -Wextra -ggdb -I. -I"$(YOSYS_SRC)" -MD -D_YOSYS_ -fPIC -I$(DESTDIR)/usr/include
LDFLAGS = -L$(DESTDIR)/lib
LDLIBS = -lstdc++ -lm
SED = sed
-@@ -359,10 +359,10 @@
+@@ -378,10 +378,10 @@
@echo ""
install: $(TARGETS) $(EXTRA_TARGETS)
@@ -42,6 +42,6 @@ Index: yosys/Makefile
+ $(INSTALL_SUDO) install $(TARGETS) $(DESTDIR)/usr/bin/
+ $(INSTALL_SUDO) mkdir -p $(DESTDIR)/usr/share/yosys
+ $(INSTALL_SUDO) cp -r share/. $(DESTDIR)/usr/share/yosys/.
-
- uninstall:
- $(INSTALL_SUDO) rm -vf $(addprefix $(DESTDIR)/bin/,$(notdir $(TARGETS)))
+ ifeq ($(ENABLE_LIBYOSYS),1)
+ $(INSTALL_SUDO) cp libyosys.so $(DESTDIR)/lib/
+ $(INSTALL_SUDO) ldconfig
diff --git a/debian/patches/05_abc_executable.patch b/debian/patches/05_abc_executable.patch
index e6b03561..d5546814 100644
--- a/debian/patches/05_abc_executable.patch
+++ b/debian/patches/05_abc_executable.patch
@@ -6,9 +6,9 @@ Forwarded: doesn't make sense upstream
Author: Ruben Undheim <ruben.undheim@gmail.com>
Index: yosys/passes/techmap/abc.cc
===================================================================
---- yosys.orig/passes/techmap/abc.cc 2015-07-24 12:07:08.559415094 +0200
-+++ yosys/passes/techmap/abc.cc 2015-07-24 12:12:33.764281530 +0200
-@@ -1264,7 +1264,7 @@
+--- yosys.orig/passes/techmap/abc.cc 2015-10-07 23:55:52.445519056 +0400
++++ yosys/passes/techmap/abc.cc 2015-10-07 23:55:52.441518840 +0400
+@@ -1270,7 +1270,7 @@
log_header("Executing ABC pass (technology mapping using ABC).\n");
log_push();
diff --git a/debian/patches/06_cflags_ldflags.patch b/debian/patches/06_cflags_ldflags.patch
index 9628df14..7a77556a 100644
--- a/debian/patches/06_cflags_ldflags.patch
+++ b/debian/patches/06_cflags_ldflags.patch
@@ -4,42 +4,30 @@ Forwarded: will do
Author: Ruben Undheim <ruben.undheim@gmail.com>
Index: yosys/Makefile
===================================================================
---- yosys.orig/Makefile 2015-07-24 12:12:50.288168224 +0200
-+++ yosys/Makefile 2015-07-24 12:12:50.288168224 +0200
-@@ -36,8 +36,8 @@
- all: top-all
+--- yosys.orig/Makefile 2015-10-07 23:56:09.422434236 +0400
++++ yosys/Makefile 2015-10-07 23:57:01.005214928 +0400
+@@ -39,8 +39,8 @@
+ YOSYS_SRC := $(dir $(firstword $(MAKEFILE_LIST)))
+ VPATH := $(YOSYS_SRC)
- YOSYS_SRC := $(shell pwd)
--CXXFLAGS = -Wall -Wextra -ggdb -I"$(YOSYS_SRC)" -MD -D_YOSYS_ -fPIC -I$(DESTDIR)/usr/include
+-CXXFLAGS = -Wall -Wextra -ggdb -I. -I"$(YOSYS_SRC)" -MD -D_YOSYS_ -fPIC -I$(DESTDIR)/usr/include
-LDFLAGS = -L$(DESTDIR)/lib
-+CXXFLAGS += -Wall -Wextra -ggdb -I"$(YOSYS_SRC)" -MD -D_YOSYS_ -fPIC -I$(DESTDIR)/usr/include
++CXXFLAGS += -Wall -Wextra -ggdb -I. -I"$(YOSYS_SRC)" -MD -D_YOSYS_ -fPIC -I$(DESTDIR)/usr/include
+LDFLAGS += -L$(DESTDIR)/lib
LDLIBS = -lstdc++ -lm
SED = sed
BISON = bison
-@@ -289,10 +289,10 @@
- $(P) $(CXX) -o yosys$(EXE) $(LDFLAGS) $(OBJS) $(LDLIBS)
+@@ -307,11 +307,11 @@
%.o: %.cc
+ $(Q) mkdir -p $(dir $@)
- $(P) $(CXX) -o $@ -c $(CXXFLAGS) $<
+ $(P) $(CXX) -o $@ -c $(CPPFLAGS) $(CXXFLAGS) $<
%.o: %.cpp
+ $(Q) mkdir -p $(dir $@)
- $(P) $(CXX) -o $@ -c $(CXXFLAGS) $<
+ $(P) $(CXX) -o $@ -c $(CPPFLAGS) $(CXXFLAGS) $<
- kernel/version_$(GIT_REV).cc: Makefile
+ kernel/version_$(GIT_REV).cc: $(YOSYS_SRC)/Makefile
$(P) rm -f kernel/version_*.o kernel/version_*.d kernel/version_*.cc
-@@ -300,9 +300,9 @@
- $(CXX) --version | tr ' ()' '\n' | grep '^[0-9]' | head -n1` $(filter -f% -m% -O% -DNDEBUG,$(CXXFLAGS)))\"; }" > kernel/version_$(GIT_REV).cc
-
- yosys-config: misc/yosys-config.in
-- $(P) $(SED) -e 's,@CXXFLAGS@,$(subst -I"$(YOSYS_SRC)",-I"$(TARGET_DATDIR)/include",$(CXXFLAGS)),;' \
-- -e 's,@CXX@,$(CXX),;' -e 's,@LDFLAGS@,$(LDFLAGS),;' -e 's,@LDLIBS@,$(LDLIBS),;' \
-- -e 's,@BINDIR@,$(TARGET_BINDIR),;' -e 's,@DATDIR@,$(TARGET_DATDIR),;' < misc/yosys-config.in > yosys-config
-+ $(P) $(SED) -e 's#@CXXFLAGS@#$(subst -I"$(YOSYS_SRC)",-I"$(TARGET_DATDIR)/include",$(CXXFLAGS))#;' \
-+ -e 's#@CXX@#$(CXX)#;' -e 's#@LDFLAGS@#$(LDFLAGS)#;' -e 's#@LDLIBS@#$(LDLIBS)#;' \
-+ -e 's#@BINDIR@#$(TARGET_BINDIR)#;' -e 's#@DATDIR@#$(TARGET_DATDIR)#;' < misc/yosys-config.in > yosys-config
- $(Q) chmod +x yosys-config
-
- abc/abc-$(ABCREV)$(EXE):