summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRuben Undheim <ruben.undheim@gmail.com>2014-09-05 23:00:35 +0200
committerRuben Undheim <ruben.undheim@gmail.com>2014-09-05 23:00:35 +0200
commitfb1d2327b51c1653b733b81db6ca8edf92e14503 (patch)
treedba7df99ae750fb77e94f0ef16aa0e5db6d9f274
parent4dfe757e294669ddaf1f64e35cb0a2b1af01610a (diff)
Fixed a few lintians
-rw-r--r--debian/control9
-rw-r--r--debian/copyright4
-rw-r--r--debian/postinst.ex39
-rw-r--r--debian/postrm.ex37
-rw-r--r--debian/preinst.ex35
-rw-r--r--debian/prerm.ex38
-rw-r--r--debian/yosys.110
7 files changed, 12 insertions, 160 deletions
diff --git a/debian/control b/debian/control
index ef3953b7..c6a729e2 100644
--- a/debian/control
+++ b/debian/control
@@ -1,11 +1,12 @@
Source: yosys
-Section: universe/electronics
-Priority: extra
+Section: electronics
+Priority: optional
Maintainer: Ruben Undheim <ruben.undheim@gmail.com>
Build-Depends: debhelper (>= 9), tcl8.5-dev, libqt4-dev, libqt4-opengl-dev, libqtwebkit-dev, libreadline-dev, git, zlib1g-dev, bison, flex, iverilog, minisat
-Standards-Version: 3.9.2
+Standards-Version: 3.9.5
+Vcs-Git: git://github.com/rubund/yosys.git -b debian
+Vcs-Browser: https://github.com/rubund/yosys/tree/debian
Homepage: http://www.clifford.at/yosys
-#Vcs-Git: https://github.com/cliffordwolf/yosys.git
Package: yosys
Architecture: any
diff --git a/debian/copyright b/debian/copyright
index 388eca8c..deb0e56e 100644
--- a/debian/copyright
+++ b/debian/copyright
@@ -1,4 +1,4 @@
-Format: http://dep.debian.net/deps/dep5
+Format: http://www.debian.org/doc/packaging-manuals/copyright-format/1.0/
Upstream-Name: yosys
Source: http://www.clifford.at/yosys/
@@ -8,7 +8,7 @@ License: ISC License
Permission to use, copy, modify, and/or distribute this software for any
purpose with or without fee is hereby granted, provided that the above
copyright notice and this permission notice appear in all copies.
-
+ .
THE SOFTWARE IS PROVIDED "AS IS" AND THE AUTHOR DISCLAIMS ALL WARRANTIES
WITH REGARD TO THIS SOFTWARE INCLUDING ALL IMPLIED WARRANTIES OF
MERCHANTABILITY AND FITNESS. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR
diff --git a/debian/postinst.ex b/debian/postinst.ex
deleted file mode 100644
index 3a9b4a0a..00000000
--- a/debian/postinst.ex
+++ /dev/null
@@ -1,39 +0,0 @@
-#!/bin/sh
-# postinst script for yosys
-#
-# see: dh_installdeb(1)
-
-set -e
-
-# summary of how this script can be called:
-# * <postinst> `configure' <most-recently-configured-version>
-# * <old-postinst> `abort-upgrade' <new version>
-# * <conflictor's-postinst> `abort-remove' `in-favour' <package>
-# <new-version>
-# * <postinst> `abort-remove'
-# * <deconfigured's-postinst> `abort-deconfigure' `in-favour'
-# <failed-install-package> <version> `removing'
-# <conflicting-package> <version>
-# for details, see http://www.debian.org/doc/debian-policy/ or
-# the debian-policy package
-
-
-case "$1" in
- configure)
- ;;
-
- abort-upgrade|abort-remove|abort-deconfigure)
- ;;
-
- *)
- echo "postinst called with unknown argument \`$1'" >&2
- exit 1
- ;;
-esac
-
-# dh_installdeb will replace this with shell code automatically
-# generated by other debhelper scripts.
-
-#DEBHELPER#
-
-exit 0
diff --git a/debian/postrm.ex b/debian/postrm.ex
deleted file mode 100644
index 98fc96c2..00000000
--- a/debian/postrm.ex
+++ /dev/null
@@ -1,37 +0,0 @@
-#!/bin/sh
-# postrm script for yosys
-#
-# see: dh_installdeb(1)
-
-set -e
-
-# summary of how this script can be called:
-# * <postrm> `remove'
-# * <postrm> `purge'
-# * <old-postrm> `upgrade' <new-version>
-# * <new-postrm> `failed-upgrade' <old-version>
-# * <new-postrm> `abort-install'
-# * <new-postrm> `abort-install' <old-version>
-# * <new-postrm> `abort-upgrade' <old-version>
-# * <disappearer's-postrm> `disappear' <overwriter>
-# <overwriter-version>
-# for details, see http://www.debian.org/doc/debian-policy/ or
-# the debian-policy package
-
-
-case "$1" in
- purge|remove|upgrade|failed-upgrade|abort-install|abort-upgrade|disappear)
- ;;
-
- *)
- echo "postrm called with unknown argument \`$1'" >&2
- exit 1
- ;;
-esac
-
-# dh_installdeb will replace this with shell code automatically
-# generated by other debhelper scripts.
-
-#DEBHELPER#
-
-exit 0
diff --git a/debian/preinst.ex b/debian/preinst.ex
deleted file mode 100644
index 7461a63f..00000000
--- a/debian/preinst.ex
+++ /dev/null
@@ -1,35 +0,0 @@
-#!/bin/sh
-# preinst script for yosys
-#
-# see: dh_installdeb(1)
-
-set -e
-
-# summary of how this script can be called:
-# * <new-preinst> `install'
-# * <new-preinst> `install' <old-version>
-# * <new-preinst> `upgrade' <old-version>
-# * <old-preinst> `abort-upgrade' <new-version>
-# for details, see http://www.debian.org/doc/debian-policy/ or
-# the debian-policy package
-
-
-case "$1" in
- install|upgrade)
- ;;
-
- abort-upgrade)
- ;;
-
- *)
- echo "preinst called with unknown argument \`$1'" >&2
- exit 1
- ;;
-esac
-
-# dh_installdeb will replace this with shell code automatically
-# generated by other debhelper scripts.
-
-#DEBHELPER#
-
-exit 0
diff --git a/debian/prerm.ex b/debian/prerm.ex
deleted file mode 100644
index a5aee247..00000000
--- a/debian/prerm.ex
+++ /dev/null
@@ -1,38 +0,0 @@
-#!/bin/sh
-# prerm script for yosys
-#
-# see: dh_installdeb(1)
-
-set -e
-
-# summary of how this script can be called:
-# * <prerm> `remove'
-# * <old-prerm> `upgrade' <new-version>
-# * <new-prerm> `failed-upgrade' <old-version>
-# * <conflictor's-prerm> `remove' `in-favour' <package> <new-version>
-# * <deconfigured's-prerm> `deconfigure' `in-favour'
-# <package-being-installed> <version> `removing'
-# <conflicting-package> <version>
-# for details, see http://www.debian.org/doc/debian-policy/ or
-# the debian-policy package
-
-
-case "$1" in
- remove|upgrade|deconfigure)
- ;;
-
- failed-upgrade)
- ;;
-
- *)
- echo "prerm called with unknown argument \`$1'" >&2
- exit 1
- ;;
-esac
-
-# dh_installdeb will replace this with shell code automatically
-# generated by other debhelper scripts.
-
-#DEBHELPER#
-
-exit 0
diff --git a/debian/yosys.1 b/debian/yosys.1
index b4babcd5..2f4c0550 100644
--- a/debian/yosys.1
+++ b/debian/yosys.1
@@ -2,7 +2,7 @@
.\" First parameter, NAME, should be all caps
.\" Second parameter, SECTION, should be 1-8, maybe w/ subsection
.\" other parameters are allowed: see man(7), man(1)
-.TH YOSYS SECTION "April 12, 2014"
+.TH YOSYS 1 "April 12, 2014"
.\" Please adjust this date whenever revising the manpage.
.\"
.\" Some roff macros, for reference:
@@ -19,7 +19,7 @@
yosys \- Yosys Open SYnthesis Suite
.SH SYNOPSIS
.B yosys
-.RI [-V]\ [-S]\ [-q]\ [-v\ <level>\ [-t]\ [-l\ <logfile>]\ [-o\ <outfile>]\ [-f\ <frontend>]\ [-h\ cmd]\ [{-s|-c}\ <scriptfile>]\ [-p\ <pass>\ [-p\ ..]]\ [-b\ <backend>]\ [-m\ <module\_file>]\ [<infile>\ [..]]
+.RI [\-V]\ [\-S]\ [\-q]\ [\-v\ <level>\ [\-t]\ [\-l\ <logfile>]\ [\-o\ <outfile>]\ [\-f\ <frontend>]\ [\-h\ cmd]\ [{\-s|\-c}\ <scriptfile>]\ [\-p\ <pass>\ [\-p\ ..]]\ [\-b\ <backend>]\ [\-m\ <module\_file>]\ [<infile>\ [..]]
.SH DESCRIPTION
This manual page documents briefly the
.B yosys
@@ -36,7 +36,7 @@ A summary of options is included below.
quiet operation. only write error message to console
.TP
.B \-v <level>
-print log headers up to level <level> to the console. (implies -q)
+print log headers up to level <level> to the console. (implies \-q)
.TP
.B \-t
annotate all log messages with a time stamp
@@ -72,10 +72,10 @@ load the specified module (aka plugin)
print version information and exit
.TP
.B \-S
-The option -S is an alias for the following options that perform a simple
+The option \-S is an alias for the following options that perform a simple
transformation of the input to a gate-level netlist.
- -p hierarchy -p proc -p opt -p memory -p opt -p techmap -p opt
+ \-p hierarchy \-p proc \-p opt \-p memory \-p opt \-p techmap \-p opt
.SH AUTHOR
yosys was written by Clifford Wolf <clifford@clifford.at>.
.PP