summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorClifford Wolf <clifford@clifford.at>2015-02-08 00:01:31 +0100
committerClifford Wolf <clifford@clifford.at>2015-02-08 00:01:31 +0100
commit0da320f151a343fc89f1fc94689f5921ed8fe4ea (patch)
treec434065f5355441f4fac9119c208213870c530f1 /Makefile
parent2ef812d67e842e65dd9fbb8df3091325d22dfba9 (diff)
Cleanup in add_share_file make macro
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/Makefile b/Makefile
index 8a2b6cdc..fcd166a1 100644
--- a/Makefile
+++ b/Makefile
@@ -159,10 +159,10 @@ CXXFLAGS += -DYOSYS_ENABLE_COVER
endif
define add_share_file
-EXTRA_TARGETS += $(1)/$(notdir $(2))
-$(1)/$(notdir $(2)): $(2)
+EXTRA_TARGETS += $(subst //,/,$(1)/$(notdir $(2)))
+$(subst //,/,$(1)/$(notdir $(2))): $(2)
$$(P) mkdir -p $(1)
- $$(Q) cp $(2) $(1)/$(notdir $(2))
+ $$(Q) cp $(2) $(subst //,/,$(1)/$(notdir $(2)))
endef
define add_include_file