summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorLarry Doolittle <ldoolitt@recycle.lbl.gov>2015-08-14 13:46:22 -0700
committerClifford Wolf <clifford@clifford.at>2015-08-14 23:27:19 +0200
commit1e67b2991916077260fbaf8679608c07375a19ac (patch)
tree5f9098c60e50632e16d99b9237e072928f584a47 /Makefile
parent6c00704a5ef09be46b1f05e2be477e493f37dd38 (diff)
Fix version strings for out-of-tree builds
Still assumes source tree is a git repository
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 6585ca39..30087380 100644
--- a/Makefile
+++ b/Makefile
@@ -60,8 +60,8 @@ else
LDLIBS += -lrt
endif
-YOSYS_VER := 0.5+$(shell test -d .git && { git log --author=clifford@clifford.at --oneline c3c9fbfb8c678.. | wc -l; })
-GIT_REV := $(shell git rev-parse --short HEAD 2> /dev/null || echo UNKNOWN)
+YOSYS_VER := 0.5+$(shell cd $(YOSYS_SRC) && test -d .git && { git log --author=clifford@clifford.at --oneline c3c9fbfb8c678.. | wc -l; })
+GIT_REV := $(shell cd $(YOSYS_SRC) && git rev-parse --short HEAD 2> /dev/null || echo UNKNOWN)
OBJS = kernel/version_$(GIT_REV).o
# set 'ABCREV = default' to use abc/ as it is