summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorSiesh1oo <siesh1oo@siesh1oo.no>2014-03-10 20:06:46 +0100
committerSiesh1oo <siesh1oo@siesh1oo.no>2014-03-10 20:06:46 +0100
commit4d56e23e318a6739ec06ce74d81dfa1d940aef0f (patch)
tree38e65b00ebd42dc6c478a0cd55085e24e87d4730 /Makefile
parent2f2e76ac68dc8da8618ebbf602e2c871f5d4b1b8 (diff)
- Makefile: export PATH=${DESTDIR}/bin:$(PATH) and (DY)LD_LIBRARY_PATH, to make sure our local copies of built executables and libraries are used.
- Makefile: use find expression in target 'yosys-svgviewer' to find svgviewer binary (qmake will build into .app package on OSX). - Makefile: make 'test' target dependent on $(TARGETS) and $(EXTRA_TARGETS) to make sure that minisat is built.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 7bd8a450..82c09d05 100644
--- a/Makefile
+++ b/Makefile
@@ -27,13 +27,17 @@ CXXFLAGS = -Wall -Wextra -ggdb -I"$(shell pwd)" -I${DESTDIR}/include -MD -D_YOSY
LDFLAGS = -I${DESTDIR}/lib
LDLIBS = -lstdc++ -lreadline -lm -ldl
+export PATH := ${DESTDIR}/bin:$(PATH)
+
ifeq (Darwin,$(findstring Darwin,$(shell uname)))
# add macports include and library path to search directories, don't use '-rdynamic' and '-lrt':
+ export DYLD_LIBRARY_PATH := ${DESTDIR}/lib:$(DYLD_LIBRARY_PATH)
CXXFLAGS += -I/opt/local/include
LDFLAGS += -L/opt/local/lib
QMAKE = qmake
SED = gsed
else
+ export LD_LIBRARY_PATH := ${DESTDIR}/lib:$(LD_LIBRARY_PATH)
LDFLAGS += -rdynamic
LDLIBS += -lrt
QMAKE = qmake-qt4
@@ -142,7 +146,7 @@ yosys-config: yosys-config.in
yosys-svgviewer: libs/svgviewer/*.h libs/svgviewer/*.cpp
cd libs/svgviewer && $(QMAKE) && make
- cp libs/svgviewer/svgviewer yosys-svgviewer
+ cp `find libs/svgviewer -name svgviewer -type f` yosys-svgviewer
yosys-minisat: $(DESTDIR)/bin/minisat
$(DESTDIR)/bin/minisat:
@@ -172,7 +176,7 @@ endif
yosys-abc: abc/abc-$(ABCREV)
cp abc/abc-$(ABCREV) yosys-abc
-test: yosys
+test: $(TARGETS) $(EXTRA_TARGETS)
cd tests/simple && bash run-test.sh
cd tests/hana && bash run-test.sh
cd tests/asicworld && bash run-test.sh