summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorClifford Wolf <clifford@clifford.at>2015-02-05 23:39:26 +0100
committerClifford Wolf <clifford@clifford.at>2015-02-05 23:39:26 +0100
commitac7d5e06584b31265d83d59cc2d60cf436551697 (patch)
tree5d747d229e5dc8b1eb2d20b953b048ebea262627 /Makefile
parenta038787c9b51e92440cac3a38801c08f66dbb3af (diff)
Auto-detect TCL version
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 1ca7f2fb..da174497 100644
--- a/Makefile
+++ b/Makefile
@@ -123,7 +123,7 @@ LDLIBS += $(shell pkg-config --silence-errors --libs libffi || echo -lffi) -ldl
endif
ifeq ($(ENABLE_TCL),1)
-TCL_VERSION ?= tcl8.5
+TCL_VERSION ?= tcl$(shell echo 'puts [info tclversion]' | tclsh)
TCL_INCLUDE ?= /usr/include/$(TCL_VERSION)
CXXFLAGS += -I$(TCL_INCLUDE) -DYOSYS_ENABLE_TCL
LDLIBS += -l$(TCL_VERSION)