summaryrefslogtreecommitdiff
path: root/backends/smt2/Makefile.inc
diff options
context:
space:
mode:
authorRuben Undheim <ruben.undheim@gmail.com>2018-07-27 18:46:13 +0000
committerRuben Undheim <ruben.undheim@gmail.com>2019-10-18 23:27:34 +0200
commit26bb69989959012cc73bd39926d818498e0474dc (patch)
treeaec628557c30c95ca9152c63cd026147e1eb6fd5 /backends/smt2/Makefile.inc
parent616d037e6820c67ec374977f80deeac4f8ca9816 (diff)
Fix adding of sys.path in yosys-smtbmc
Gbp-Pq: Name 0010-Fix-adding-of-sys.path-in-yosys-smtbmc.patch
Diffstat (limited to 'backends/smt2/Makefile.inc')
-rw-r--r--backends/smt2/Makefile.inc2
1 files changed, 1 insertions, 1 deletions
diff --git a/backends/smt2/Makefile.inc b/backends/smt2/Makefile.inc
index 92941d4c..2c0b7c69 100644
--- a/backends/smt2/Makefile.inc
+++ b/backends/smt2/Makefile.inc
@@ -22,7 +22,7 @@ else
TARGETS += yosys-smtbmc
yosys-smtbmc: backends/smt2/smtbmc.py
- $(P) sed 's|##yosys-sys-path##|sys.path += [os.path.dirname(os.path.realpath(__file__)) + p for p in ["/share/python3", "/../share/yosys/python3"]]|;' < $< > $@.new
+ $(P) sed 's|##yosys-sys-path##|sys.path += ["/usr/share/yosys"]|;' < $< > $@.new
$(Q) chmod +x $@.new
$(Q) mv $@.new $@
endif