summaryrefslogtreecommitdiff
path: root/debian/patches
diff options
context:
space:
mode:
authorRuben Undheim <ruben.undheim@gmail.com>2014-09-05 22:23:34 +0200
committerRuben Undheim <ruben.undheim@gmail.com>2014-09-05 22:23:34 +0200
commit6927e108441df2fd19d99e0fffd0c5f501676daa (patch)
tree6ca363823a6d2de50c5feeef2892c61e73ab6248 /debian/patches
parent0b42e00373493ecace932b9cdeaf9fd24386a448 (diff)
Updated patches and rules
Diffstat (limited to 'debian/patches')
-rw-r--r--debian/patches/02_removeabc.patch36
-rw-r--r--debian/patches/03_notruntests.patch55
-rw-r--r--debian/patches/04_installpath.patch12
3 files changed, 46 insertions, 57 deletions
diff --git a/debian/patches/02_removeabc.patch b/debian/patches/02_removeabc.patch
index 90eb6b96..68fec7ec 100644
--- a/debian/patches/02_removeabc.patch
+++ b/debian/patches/02_removeabc.patch
@@ -1,35 +1,9 @@
-Index: yosys-0.2.0+/tests/techmap/mem_simple_4x1_runtest.sh
+Index: yosys/Makefile
===================================================================
---- yosys-0.2.0+.orig/tests/techmap/mem_simple_4x1_runtest.sh 2014-04-12 19:30:08.803862768 +0200
-+++ yosys-0.2.0+/tests/techmap/mem_simple_4x1_runtest.sh 2014-04-13 00:29:23.212015340 +0200
-@@ -2,7 +2,7 @@
-
- set -ev
-
--../../yosys -b 'verilog -noattr' -o mem_simple_4x1_synth.v -p 'proc; opt; memory -nomap; techmap -map mem_simple_4x1_map.v;; techmap; opt; abc;; stat' mem_simple_4x1_uut.v
-+../../yosys -b 'verilog -noattr' -o mem_simple_4x1_synth.v -p 'proc; opt; memory -nomap; techmap -map mem_simple_4x1_map.v;; techmap; opt;; stat' mem_simple_4x1_uut.v
-
- iverilog -o mem_simple_4x1_gold_tb mem_simple_4x1_tb.v mem_simple_4x1_uut.v
- iverilog -o mem_simple_4x1_gate_tb mem_simple_4x1_tb.v mem_simple_4x1_synth.v mem_simple_4x1_cells.v
-Index: yosys-0.2.0+/tests/tools/autotest.sh
-===================================================================
---- yosys-0.2.0+.orig/tests/tools/autotest.sh 2014-04-13 00:02:10.756001468 +0200
-+++ yosys-0.2.0+/tests/tools/autotest.sh 2014-04-13 00:29:59.112015646 +0200
-@@ -126,7 +126,7 @@
- test_passes -p "verific -vlog2k $fn; verific -import -gates -all; opt; memory;;"
- else
- test_passes -f "$frontend" -p "hierarchy; proc; opt; memory; opt; fsm; opt" $fn
-- test_passes -f "$frontend" -p "hierarchy; proc; opt; memory; opt; fsm; opt; techmap; opt; abc -dff; opt" $fn
-+ test_passes -f "$frontend" -p "hierarchy; proc; opt; memory; opt; fsm; opt; techmap; opt; " $fn
- fi
- touch ../${bn}.log
- }
-Index: yosys-0.2.0+/Makefile
-===================================================================
---- yosys-0.2.0+.orig/Makefile 2014-04-13 02:59:27.656091856 +0200
-+++ yosys-0.2.0+/Makefile 2014-04-13 02:59:49.564092043 +0200
-@@ -85,9 +85,9 @@
- TARGETS += yosys-svgviewer
+--- yosys.orig/Makefile 2014-09-05 22:17:14.586545422 +0200
++++ yosys/Makefile 2014-09-05 22:17:29.818545586 +0200
+@@ -110,9 +110,9 @@
+ LDFLAGS += -pg
endif
-ifeq ($(ENABLE_ABC),1)
diff --git a/debian/patches/03_notruntests.patch b/debian/patches/03_notruntests.patch
index 6624e9ab..e52d3805 100644
--- a/debian/patches/03_notruntests.patch
+++ b/debian/patches/03_notruntests.patch
@@ -1,32 +1,47 @@
-Index: yosys-0.2.0+/Makefile
+Index: yosys/Makefile
===================================================================
---- yosys-0.2.0+.orig/Makefile 2014-04-13 00:02:10.768001468 +0200
-+++ yosys-0.2.0+/Makefile 2014-04-13 00:18:25.476009751 +0200
-@@ -157,12 +157,12 @@
+--- yosys.orig/Makefile 2014-09-05 22:18:08.594546002 +0200
++++ yosys/Makefile 2014-09-05 22:19:16.926546735 +0200
+@@ -233,20 +233,20 @@
yosys-abc: abc/abc-$(ABCREV)
- cp abc/abc-$(ABCREV) yosys-abc
+ $(P) cp abc/abc-$(ABCREV) yosys-abc
-test: $(TARGETS) $(EXTRA_TARGETS)
-- cd tests/simple && bash run-test.sh
-- cd tests/hana && bash run-test.sh
-- cd tests/asicworld && bash run-test.sh
-- cd tests/techmap && bash run-test.sh
-- cd tests/sat && bash run-test.sh
+- +cd tests/simple && bash run-test.sh
+- +cd tests/hana && bash run-test.sh
+- +cd tests/asicworld && bash run-test.sh
+- +cd tests/realmath && bash run-test.sh
+- +cd tests/share && bash run-test.sh
+- +cd tests/fsm && bash run-test.sh
+- +cd tests/techmap && bash run-test.sh
+- +cd tests/memories && bash run-test.sh
+- +cd tests/various && bash run-test.sh
+- +cd tests/sat && bash run-test.sh
+- @echo ""
+- @echo " Passed \"make test\"."
+- @echo ""
+#test: $(TARGETS) $(EXTRA_TARGETS)
-+# cd tests/simple && bash run-test.sh
-+# cd tests/hana && bash run-test.sh
-+# cd tests/asicworld && bash run-test.sh
-+# cd tests/techmap && bash run-test.sh
-+# cd tests/sat && bash run-test.sh
++# +cd tests/simple && bash run-test.sh
++# +cd tests/hana && bash run-test.sh
++# +cd tests/asicworld && bash run-test.sh
++# +cd tests/realmath && bash run-test.sh
++# +cd tests/share && bash run-test.sh
++# +cd tests/fsm && bash run-test.sh
++# +cd tests/techmap && bash run-test.sh
++# +cd tests/memories && bash run-test.sh
++# +cd tests/various && bash run-test.sh
++# +cd tests/sat && bash run-test.sh
++# @echo ""
++# @echo " Passed \"make test\"."
++# @echo ""
- install: $(TARGETS) $(EXTRA_TARGETS)
- $(INSTALL_SUDO) mkdir -p $(DESTDIR)/bin
-@@ -219,6 +219,7 @@
+ VALGRIND ?= valgrind --error-exitcode=1 --leak-check=full --show-reachable=yes --errors-for-leak-kinds=all
+
+@@ -327,6 +327,6 @@
-include kernel/*.d
-include techlibs/*/*.d
-.PHONY: all top-all abc test install install-abc manual clean mrproper qtcreator
-+#.PHONY: all top-all abc test install install-abc manual clean mrproper qtcreator
+.PHONY: all top-all abc install install-abc manual clean mrproper qtcreator
- .PHONY: config-clean config-clang-debug config-gcc-debug config-release
+ .PHONY: config-clean config-clang config-gcc config-gcc-4.6 config-gprof config-sudo
diff --git a/debian/patches/04_installpath.patch b/debian/patches/04_installpath.patch
index 1b71456f..c5c3096b 100644
--- a/debian/patches/04_installpath.patch
+++ b/debian/patches/04_installpath.patch
@@ -1,10 +1,10 @@
-Index: yosys-0.2.0+/Makefile
+Index: yosys/Makefile
===================================================================
---- yosys-0.2.0+.orig/Makefile 2014-04-13 12:11:25.416694559 +0200
-+++ yosys-0.2.0+/Makefile 2014-04-13 12:12:00.200694857 +0200
-@@ -164,11 +164,11 @@
- # cd tests/techmap && bash run-test.sh
- # cd tests/sat && bash run-test.sh
+--- yosys.orig/Makefile 2014-09-05 22:19:51.746547108 +0200
++++ yosys/Makefile 2014-09-05 22:20:14.654547354 +0200
+@@ -262,11 +262,11 @@
+ @echo " Passed \"make vloghtb\"."
+ @echo ""
-install: $(TARGETS) $(EXTRA_TARGETS)
- $(INSTALL_SUDO) mkdir -p $(DESTDIR)/bin