summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--passes/techmap/Makefile.inc3
1 files changed, 1 insertions, 2 deletions
diff --git a/passes/techmap/Makefile.inc b/passes/techmap/Makefile.inc
index 2e90215e..97023625 100644
--- a/passes/techmap/Makefile.inc
+++ b/passes/techmap/Makefile.inc
@@ -3,8 +3,7 @@ GENFILES += passes/techmap/stdcells.inc
OBJS += passes/techmap/techmap.o
passes/techmap/stdcells.inc: techlibs/stdcells.v
- echo -n "// autogenerated from $< on " > $@.new
- LANG=C date >> $@.new
+ echo "// autogenerated from $<" > $@.new
od -v -td1 -w1 $< | awk 'BEGIN { print "static char stdcells_code[] = {"; } $$2 != "" { print $$2 ","; } \
END { print 0 "};"; }' | fmt >> $@.new
mv $@.new $@