summaryrefslogtreecommitdiff
path: root/debian/patches/0008-Set-fixed-date-when-calling-pdflatex-for-presentatio.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/0008-Set-fixed-date-when-calling-pdflatex-for-presentatio.patch')
-rw-r--r--debian/patches/0008-Set-fixed-date-when-calling-pdflatex-for-presentatio.patch52
1 files changed, 52 insertions, 0 deletions
diff --git a/debian/patches/0008-Set-fixed-date-when-calling-pdflatex-for-presentatio.patch b/debian/patches/0008-Set-fixed-date-when-calling-pdflatex-for-presentatio.patch
new file mode 100644
index 00000000..231b837a
--- /dev/null
+++ b/debian/patches/0008-Set-fixed-date-when-calling-pdflatex-for-presentatio.patch
@@ -0,0 +1,52 @@
+From: Ruben Undheim <ruben.undheim@gmail.com>
+Date: Thu, 12 Jul 2018 10:41:21 +0000
+Subject: Set fixed date when calling pdflatex for presentation.tex. Remove ID
+ fields
+
+---
+ Makefile | 2 +-
+ manual/presentation.sh | 5 ++++-
+ manual/presentation.tex | 1 +
+ 3 files changed, 6 insertions(+), 2 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index 8979641..53bab9b 100644
+--- a/Makefile
++++ b/Makefile
+@@ -464,7 +464,7 @@ update-manual: $(TARGETS) $(EXTRA_TARGETS)
+
+ manual: $(TARGETS) $(EXTRA_TARGETS)
+ cd manual && bash appnotes.sh
+- cd manual && bash presentation.sh
++ cd manual && PDF_DATE=$(PDF_DATE) bash presentation.sh
+ cd manual && bash manual.sh
+
+ clean:
+diff --git a/manual/presentation.sh b/manual/presentation.sh
+index ca8a6c9..a152484 100755
+--- a/manual/presentation.sh
++++ b/manual/presentation.sh
+@@ -37,7 +37,10 @@ fi
+
+ set -ex
+
+-pdflatex $PDFTEX_OPT presentation.tex
++echo ${PDF_DATE}
++pdflatex $PDFTEX_OPT '\pdfinfo{/CreationDate('${PDF_DATE}')/ModDate('${PDF_DATE}')}\input{presentation.tex}'
++grep -av '^/ID \[\(<[0-9A-F]\{32\}>\) \1]$$' presentation.pdf > presentation.pdf.without_pdf_id
++mv -f presentation.pdf.without_pdf_id presentation.pdf
+
+ if ! $fast_mode; then
+ while
+diff --git a/manual/presentation.tex b/manual/presentation.tex
+index 8060998..a42648c 100644
+--- a/manual/presentation.tex
++++ b/manual/presentation.tex
+@@ -81,6 +81,7 @@
+
+ \title{Yosys Open SYnthesis Suite}
+ \author{Clifford Wolf}
++\date{REPLACEWITHDATE}
+ \institute{http://www.clifford.at/yosys/}
+
+ \usetheme{Madrid}