summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSimon McVittie <smcv@debian.org>2023-12-10 22:09:55 +0000
committerSimon McVittie <smcv@debian.org>2023-12-10 22:23:59 +0000
commit8ba453a35e886dc1fbd0529a7ab26a52b2e76a22 (patch)
treefcb499bb73f93e65839b9ce5bcd92d8f6b46b3ef
parent21ff1af8fd0cb6908d7475adfe4b401b69b38f23 (diff)
Build and install game-code for the expansion packs
-rw-r--r--debian/README.source4
-rwxr-xr-xdebian/rules16
-rw-r--r--debian/yamagi-quake2-core.install14
3 files changed, 27 insertions, 7 deletions
diff --git a/debian/README.source b/debian/README.source
index c670a3f..030423d 100644
--- a/debian/README.source
+++ b/debian/README.source
@@ -1,5 +1,5 @@
Updating to a new upstream release
==================================
-Make sure to run `uscan -dd` to force the CTF source code to be
-downloaded too.
+Make sure to run `uscan -dd` to force the CTF, Rogue, Xatrix source code
+to be downloaded too.
diff --git a/debian/rules b/debian/rules
index f5e36a0..1f27cbe 100755
--- a/debian/rules
+++ b/debian/rules
@@ -47,7 +47,9 @@ else
$(error Set YQ2_OSTYPE to the value of uname -s on $(DEB_HOST_ARCH))
endif
-override_dh_auto_build:
+subdirs = subdir-ctf subdir-rogue subdir-xatrix
+
+override_dh_auto_build: $(subdirs)
dh_auto_build -- \
VERBOSE=1 \
WITH_RPATH=no \
@@ -55,15 +57,23 @@ override_dh_auto_build:
YQ2_ARCH=$(YQ2_ARCH) \
YQ2_OSTYPE=$(YQ2_OSTYPE) \
${NULL}
- dh_auto_build --sourcedirectory=ctf -- \
+
+.PHONY: $(subdirs)
+$(subdirs): subdir-%:
+ dh_auto_build --sourcedirectory=$* -- \
VERBOSE=1 \
YQ2_ARCH=$(YQ2_ARCH) \
YQ2_OSTYPE=$(YQ2_OSTYPE) \
${NULL}
override_dh_install:
- install -d debian/tmp
+ install -d debian/tmp/ctf
+ install -d debian/tmp/rogue
+ install -d debian/tmp/xatrix
install -m644 CHANGELOG debian/tmp/NEWS
+ install -m644 ctf/CHANGELOG debian/tmp/ctf/NEWS
+ install -m644 rogue/CHANGELOG debian/tmp/rogue/NEWS
+ install -m644 xatrix/CHANGELOG debian/tmp/xatrix/NEWS
dh_install
override_dh_installchangelogs:
diff --git a/debian/yamagi-quake2-core.install b/debian/yamagi-quake2-core.install
index 447b3c8..11ed0d7 100644
--- a/debian/yamagi-quake2-core.install
+++ b/debian/yamagi-quake2-core.install
@@ -1,5 +1,15 @@
+ctf/README usr/share/doc/yamagi-quake2-core/ctf
+ctf/release/game.so usr/lib/yamagi-quake2/ctf
+debian/tmp/ctf/NEWS usr/share/doc/yamagi-quake2-core/ctf
debian/tmp/NEWS usr/share/doc/yamagi-quake2-core
-release/q2ded usr/lib/yamagi-quake2
+debian/tmp/rogue/NEWS usr/share/doc/yamagi-quake2-core/rogue
+debian/tmp/xatrix/NEWS usr/share/doc/yamagi-quake2-core/xatrix
release/baseq2/game.so usr/lib/yamagi-quake2/baseq2
+release/q2ded usr/lib/yamagi-quake2
+rogue/README usr/share/doc/yamagi-quake2-core/rogue
+rogue/release/game.so usr/lib/yamagi-quake2/rogue
+rogue/stuff/mapfixes/*.ent usr/lib/yamagi-quake2/rogue/maps
stuff/mapfixes/baseq2/*.ent usr/lib/yamagi-quake2/baseq2/maps
-ctf/release/game.so usr/lib/yamagi-quake2/ctf
+xatrix/README usr/share/doc/yamagi-quake2-core/xatrix
+xatrix/release/game.so usr/lib/yamagi-quake2/xatrix
+xatrix/stuff/mapfixes/*.ent usr/lib/yamagi-quake2/xatrix/maps