summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVasudev Kamath <vasudev@copyninja.info>2018-03-25 17:05:57 +0530
committerVasudev Kamath <vasudev@copyninja.info>2018-03-25 17:05:57 +0530
commitf55e7c5be0cadb06f2df19f35d62b00a4fb3e293 (patch)
treea2c2cb848b3e29beaa9c672358654212f128b811
parentf81dc65f1b25c7795461dfbcdc15bf25567d4a56 (diff)
Drop command line tools zfec and zunfec
Command line tools depend on pyutils and zbase32 libraries which are not packaged for Debian. This patch can be dropped when the above libraries will be available in Debian. Forwarded: not-needed Last-Update: 2018-03-25 Gbp-Pq: Name 2001-drop_command_line_tools.patch
-rw-r--r--setup.cfg5
-rw-r--r--setup.py4
2 files changed, 0 insertions, 9 deletions
diff --git a/setup.cfg b/setup.cfg
index 5835bdf..831c0fc 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -49,11 +49,6 @@ classifier =
packages = find:
include_package_data = True
-[options.entry_points]
-console_scripts =
- zfec = zfec.cmdline_zfec:main
- zunfec = zfec.cmdline_zunfec:main
-
[versioneer]
vcs = git
style = pep440
diff --git a/setup.py b/setup.py
index d949d86..a82ca5f 100644
--- a/setup.py
+++ b/setup.py
@@ -49,10 +49,6 @@ extensions = [
setup(
version=versioneer.get_version(),
- install_requires=[
- "pyutil >= 3.0.0",
- "argparse >= 0.8 ; python_version <= '2.7'",
-],
ext_modules=extensions,
cmdclass=versioneer.get_cmdclass(),
)