summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHelmut Grohne <helmut@subdivi.de>2018-11-04 21:35:11 +0800
committerPaul Gevers <elbrus@debian.org>2020-12-10 09:24:21 +0100
commita95b46b9d6a5672aadc1d068e4086d6a666d76d9 (patch)
tree22f6f38201de1146af6bc5126db062c747e8f1ad
parent75c334b70b4a10c95473ae996dbbe401bbf2b032 (diff)
stop using libtool-bin
Gbp-Pq: Name 0007-stop-using-libtool-bin.patch
-rw-r--r--Makefile.am4
-rwxr-xr-xtests/setup2
2 files changed, 3 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 13f74c9..df020b1 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -118,8 +118,8 @@ endif
### Tests (make check)
-TESTS = tests/optionaltest tests/mantest tests/jqtest tests/onigtest tests/shtest tests/utf8test tests/base64test
-TESTS_ENVIRONMENT = NO_VALGRIND=$(NO_VALGRIND)
+TESTS = tests/mantest tests/jqtest tests/onigtest tests/shtest
+TESTS_ENVIRONMENT = NO_VALGRIND=$(NO_VALGRIND) LIBTOOL="$(LIBTOOL)"
### Building the manpage
diff --git a/tests/setup b/tests/setup
index 4d5f0c4..2b4e913 100755
--- a/tests/setup
+++ b/tests/setup
@@ -13,7 +13,7 @@ JQBASEDIR=$JQTESTDIR/..
JQ=$JQBASEDIR/jq
if [ -z "${NO_VALGRIND-}" ] && which valgrind > /dev/null; then
- VALGRIND="libtool --mode=execute -- valgrind \
+ VALGRIND="$LIBTOOL --mode=execute -- valgrind \
--error-exitcode=1 --leak-check=full \
--suppressions=$JQTESTDIR/onig.supp"
VG_EXIT0=--error-exitcode=0