summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Makefile.am4
-rwxr-xr-xtests/setup2
2 files changed, 3 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 13f74c9..df020b1 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -118,8 +118,8 @@ endif
### Tests (make check)
-TESTS = tests/optionaltest tests/mantest tests/jqtest tests/onigtest tests/shtest tests/utf8test tests/base64test
-TESTS_ENVIRONMENT = NO_VALGRIND=$(NO_VALGRIND)
+TESTS = tests/mantest tests/jqtest tests/onigtest tests/shtest
+TESTS_ENVIRONMENT = NO_VALGRIND=$(NO_VALGRIND) LIBTOOL="$(LIBTOOL)"
### Building the manpage
diff --git a/tests/setup b/tests/setup
index 4d5f0c4..2b4e913 100755
--- a/tests/setup
+++ b/tests/setup
@@ -13,7 +13,7 @@ JQBASEDIR=$JQTESTDIR/..
JQ=$JQBASEDIR/jq
if [ -z "${NO_VALGRIND-}" ] && which valgrind > /dev/null; then
- VALGRIND="libtool --mode=execute -- valgrind \
+ VALGRIND="$LIBTOOL --mode=execute -- valgrind \
--error-exitcode=1 --leak-check=full \
--suppressions=$JQTESTDIR/onig.supp"
VG_EXIT0=--error-exitcode=0