summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNilesh Patra <nilesh@debian.org>2023-12-27 18:01:52 +0100
committerÉtienne Mollier <emollier@debian.org>2023-12-27 18:01:52 +0100
commit98571e2416e52945910dd26ccfdecfb221ae4878 (patch)
tree1b8570d2b87d517591d309901c1bba7fa8c91941
parent3cfc9e2d6b16dc67021110ff38fdfd606913453c (diff)
Explicitly set packages field for right file
Last-Update: 2022-09-24 Gbp-Pq: Name set_package_field.patch
-rwxr-xr-xsetup.py3
1 files changed, 2 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index bf4985d..25e097a 100755
--- a/setup.py
+++ b/setup.py
@@ -12,7 +12,7 @@ details. You should have received a copy of the GNU General Public License along
not, see <http://www.gnu.org/licenses/>.
"""
-from setuptools import setup
+from setuptools import setup, find_packages
with open('README.md', 'rb') as readme:
long_description = readme.read()
@@ -27,6 +27,7 @@ exec(version_line)
setup(name='Kaptive',
version=__version__,
+ packages=find_packages(),
description='K and O locus typing for Klebsiella assemblies',
long_description=long_description,
url='http://github.com/katholt/Kaptive',