summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHelmut Grohne <helmut@subdivi.de>2022-11-04 11:18:05 +0100
committergregor herrmann <gregoa@debian.org>2022-11-23 21:21:27 +0100
commit0feed5e516c778445e4423767e4fe64d09f7609d (patch)
tree561d39120b42044fe80e2445dd4d911fa41cb4b3
parent79d32cc8831f6b057a43381226f7bccf410e868d (diff)
Fix FTCBFS: Use a triplet-prefixed compiler.
Closes: #1023487
-rw-r--r--debian/patches/cross.patch25
-rw-r--r--debian/patches/series1
-rwxr-xr-xdebian/rules3
3 files changed, 29 insertions, 0 deletions
diff --git a/debian/patches/cross.patch b/debian/patches/cross.patch
new file mode 100644
index 0000000..7aa4882
--- /dev/null
+++ b/debian/patches/cross.patch
@@ -0,0 +1,25 @@
+Description: FTCBFS: hard codes the build architecture C++ compiler
+ libsgml-parser-opensp-perl fails to cross build from source, because the
+ Makefile.PL hard codes the build architecture C++ compiler. I'm attaching a
+ patch for your convenience to make it use the host one and thus make
+ libsgml-parser-opensp-perl cross buildable.
+Origin: vendor
+Bug: https://bugs.debian.org/1023487
+Forwarded: no
+Author: Helmut Grohne <helmut@subdivi.de>
+Reviewed-by: gregor herrmann <gregoa@debian.org>
+Last-Update: 2022-11-23
+
+--- a/Makefile.PL
++++ b/Makefile.PL
+@@ -13,8 +13,8 @@
+ else
+ {
+ # assume some compatible Linux
+- $options{LD} = "g++";
+- $options{CC} = "g++";
++ $options{CC} = $ENV{CXX} || "g++";
++ $options{LD} = $options{CC};
+ $options{LIBS} = "-lstdc++ -losp";
+ }
+
diff --git a/debian/patches/series b/debian/patches/series
index d95546f..85c58d3 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1,2 +1,3 @@
doc_misspelling.patch
binnmu_rebuild_fix.patch
+cross.patch
diff --git a/debian/rules b/debian/rules
index 8b4cb26..dfe3823 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,5 +1,8 @@
#!/usr/bin/make -f
+DPKG_EXPORT_BUILDTOOLS=1
+include /usr/share/dpkg/buildtools.mk
+
PACKAGE = $(shell dh_listpackages)
TMP = $(CURDIR)/debian/$(PACKAGE)