summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHelmut Grohne <helmut@subdivi.de>2023-07-02 21:14:47 +0200
committergregor herrmann <gregoa@debian.org>2023-07-02 21:14:47 +0200
commitd992404d4f16be821cffb34b1eef52263baa6190 (patch)
tree1ca3e73f38bd54698c1d80c144fdd8a0e343b2af
parentcb7f19aa251878862d9cdfba11a1989094555750 (diff)
FTCBFS: hard codes the build architecture C++ compiler
Origin: vendor Bug: https://bugs.debian.org/1023487 Forwarded: no Reviewed-by: gregor herrmann <gregoa@debian.org> Last-Update: 2022-11-23 libsgml-parser-opensp-perl fails to cross build from source, because the Makefile.PL hard codes the build architecture C++ compiler. I'm attaching a patch for your convenience to make it use the host one and thus make libsgml-parser-opensp-perl cross buildable. Gbp-Pq: Name cross.patch
-rw-r--r--Makefile.PL4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.PL b/Makefile.PL
index f3a2eeb..46a6041 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -13,8 +13,8 @@ if ($^O eq "MSWin32")
else
{
# assume some compatible Linux
- $options{LD} = "g++";
- $options{CC} = "g++";
+ $options{CC} = $ENV{CXX} || "g++";
+ $options{LD} = $options{CC};
$options{LIBS} = "-lstdc++ -losp";
}