summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorÉtienne Mollier <emollier@debian.org>2023-08-13 00:01:53 +0200
committerÉtienne Mollier <emollier@debian.org>2023-08-13 00:01:53 +0200
commit7c3308501ca57691e37a1fda969fd786c6273dc7 (patch)
tree7a7cfdfc6e71dae0aa3533018628c21c8c022eca
parentdd2fac0d32194e99e3bdbe45217d34e6b7e49e94 (diff)
fix infinite loop with gcc 13
Bug: https://github.com/FePhyFoFum/phyx/issues/178 Bug-Debian: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=1037817 Last-Update: 2023-08-12 Since gcc 13, the superdouble operation goes in infinite loop. Disabline compilation with -ffast-math resolves the issue. Last-Update: 2023-08-12 Gbp-Pq: Name deoptimize.patch
-rw-r--r--src/Makefile.in2
1 files changed, 0 insertions, 2 deletions
diff --git a/src/Makefile.in b/src/Makefile.in
index 28681ff..7fb61dd 100644
--- a/src/Makefile.in
+++ b/src/Makefile.in
@@ -35,8 +35,6 @@ ifneq "$(CXX)" "icc"
OPT_FLAGS += -ftree-vectorize
ifneq ($(filter @host_cpu@,i386 i486 i586 i686),)
OPT_FLAGS += -ffloat-store
- else
- OPT_FLAGS += -ffast-math
endif
endif