summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrej Shadura <andrew.shadura@collabora.co.uk>2018-07-15 15:47:20 +0200
committerAndrej Shadura <andrew.shadura@collabora.co.uk>2018-07-15 15:51:40 +0200
commit543651f7ccb2244b22064cb3ae9d53b753cc5498 (patch)
tree943a2c0419cda59b9b5c521177294d207fae91ed
parent3fc74ae03d36154a3612cab9353f9f3cf1530dd0 (diff)
parentbbbd1afd333277445ff41d92a5a1a37e72b992c2 (diff)
Update upstream source from tag 'upstream/0.3.1'
Update to upstream version '0.3.1' with Debian dir 78288b980aed3a9bf6497ef4b7fbe0c230890778 Drop the patch applied upstream.
-rw-r--r--PKG-INFO2
-rw-r--r--debian/patches/0001-Convert-to-RGB-before-saving-as-JPEG.patch27
-rw-r--r--debian/patches/series1
-rw-r--r--docs/conf.py4
-rw-r--r--docs/releasenotes.rst10
-rw-r--r--pydenticon.egg-info/PKG-INFO2
-rw-r--r--setup.py2
7 files changed, 15 insertions, 33 deletions
diff --git a/PKG-INFO b/PKG-INFO
index 8e48c91..bf7361f 100644
--- a/PKG-INFO
+++ b/PKG-INFO
@@ -1,6 +1,6 @@
Metadata-Version: 1.1
Name: pydenticon
-Version: 0.3
+Version: 0.3.1
Summary: Library for generating identicons. Port of Sigil (https://github.com/cupcake/sigil) with enhancements.
Home-page: https://github.com/azaghal/pydenticon
Author: Branko Majic
diff --git a/debian/patches/0001-Convert-to-RGB-before-saving-as-JPEG.patch b/debian/patches/0001-Convert-to-RGB-before-saving-as-JPEG.patch
deleted file mode 100644
index 15a87f8..0000000
--- a/debian/patches/0001-Convert-to-RGB-before-saving-as-JPEG.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-From 4f66550c14238b18dc95f2c40e8e9f1b704de675 Mon Sep 17 00:00:00 2001
-From: Andrew Shadura <andrewsh@debian.org>
-Date: Sun, 3 Sep 2017 10:04:49 +0200
-Subject: [PATCH] Convert to RGB before saving as JPEG.
-
-Pillow 3.7 removes support for saving RGBA images as JPEG.
----
- pydenticon/__init__.py | 3 +++
- 1 file changed, 3 insertions(+)
-
-diff --git a/pydenticon/__init__.py b/pydenticon/__init__.py
-index 0edfdb0..f499988 100644
---- a/pydenticon/__init__.py
-+++ b/pydenticon/__init__.py
-@@ -246,6 +246,9 @@ class Generator(object):
- # Set-up a stream where image will be saved.
- stream = BytesIO()
-
-+ if image_format.upper() == "JPEG":
-+ image = image.convert(mode="RGB")
-+
- # Save the image to stream.
- try:
- image.save(stream, format=image_format, optimize=True)
---
-2.11.0
-
diff --git a/debian/patches/series b/debian/patches/series
deleted file mode 100644
index 16fa444..0000000
--- a/debian/patches/series
+++ /dev/null
@@ -1 +0,0 @@
-0001-Convert-to-RGB-before-saving-as-JPEG.patch
diff --git a/docs/conf.py b/docs/conf.py
index ac49123..90a12d3 100644
--- a/docs/conf.py
+++ b/docs/conf.py
@@ -49,9 +49,9 @@ copyright = u'2013, Branko Majic'
# built documents.
#
# The short X.Y version.
-version = '0.3'
+version = '0.3.1'
# The full version, including alpha/beta/rc tags.
-release = '0.3'
+release = '0.3.1'
# The language for content autogenerated by Sphinx. Refer to documentation
# for a list of supported languages.
diff --git a/docs/releasenotes.rst b/docs/releasenotes.rst
index 15b5b45..3debd98 100644
--- a/docs/releasenotes.rst
+++ b/docs/releasenotes.rst
@@ -1,6 +1,16 @@
Release Notes
=============
+0.3.1
+-----
+
+Minor bug-fixes.
+
+Bug fixes:
+
+* `PYD-8 - Cannot generate identicons in JPEG format when using Pillow >= 4.2.0
+ <https://projects.majic.rs/pydenticon/issues/PYD-8>`_
+
0.3
---
diff --git a/pydenticon.egg-info/PKG-INFO b/pydenticon.egg-info/PKG-INFO
index 8e48c91..bf7361f 100644
--- a/pydenticon.egg-info/PKG-INFO
+++ b/pydenticon.egg-info/PKG-INFO
@@ -1,6 +1,6 @@
Metadata-Version: 1.1
Name: pydenticon
-Version: 0.3
+Version: 0.3.1
Summary: Library for generating identicons. Port of Sigil (https://github.com/cupcake/sigil) with enhancements.
Home-page: https://github.com/azaghal/pydenticon
Author: Branko Majic
diff --git a/setup.py b/setup.py
index c572f75..6bc246e 100644
--- a/setup.py
+++ b/setup.py
@@ -10,7 +10,7 @@ os.chdir(os.path.normpath(os.path.join(os.path.abspath(__file__), os.pardir)))
setup(
name='pydenticon',
- version='0.3',
+ version='0.3.1',
packages=['pydenticon'],
include_package_data=True,
license='BSD', # example license