summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorJonas Smedegaard <dr@jones.dk>2016-12-28 00:34:02 +0100
committerJonas Smedegaard <dr@jones.dk>2016-12-28 00:35:26 +0100
commitcc9a1f25308d5daefc233b7188163b88cb5426d9 (patch)
tree97ac92e4f00937cd3b7832fdc05a0029cdfdd183 /debian/rules
parent9214a724808e07d9a891512fee95dcfb9da0a1df (diff)
Simplify build: Let CDBS handle build and install.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules24
1 files changed, 10 insertions, 14 deletions
diff --git a/debian/rules b/debian/rules
index b608f17..9be2aab 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,7 +1,7 @@
#!/usr/bin/make -f
include /usr/share/cdbs/1/rules/utils.mk
-include /usr/share/cdbs/1/class/langcore.mk
+include /usr/share/cdbs/1/class/makefile.mk
include /usr/share/cdbs/1/rules/debhelper.mk
# Ignore wav files
@@ -42,21 +42,17 @@ endef
$(foreach module,ffmpeg gstreamer gtk x11,\
$(eval $(call MODULE_template,$(module))))
+DEB_MAKE_EXTRA_ARGS = V=1 PREFIX=/usr RELEASE=1 \
+ EXTRA_MODULES="$(EXTRA_MODULES)" \
+ EXTRA_CFLAGS="$(CFLAGS) $(CPPFLAGS)" \
+ EXTRA_LFLAGS="$(LDFLAGS)" \
+ $(DEB_MAKE_PARALLEL)
+
+DEB_MAKE_BUILD_TARGET = info all
+DEB_MAKE_INSTALL_TARGET = install DESTDIR=$(cdbs_make_curdestdir)
+
DEB_INSTALL_DOCS_ALL += README.md docs/TODO
DEB_INSTALL_EXAMPLES_$(pkg) = docs/examples/*
# LIBDIR for installation
LIBDIR=/usr/lib
-
-# TODO: Drop when makefiles.mk can handle the package
-common-build-arch common-build-indep:: build_rem_package
-build_rem_package:
- make info all V=1 PREFIX=/usr RELEASE=1 \
- EXTRA_CFLAGS="$(CFLAGS) $(CPPFLAGS)" \
- EXTRA_LFLAGS="$(LDFLAGS)" \
- EXTRA_MODULES="$(EXTRA_MODULES)"
-
-common-install-arch common-install-indep:: install_rem_package
-install_rem_package:
- make install DESTDIR=debian/tmp V=1 PREFIX=/usr \
- EXTRA_MODULES="$(EXTRA_MODULES)"