summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDidier Raboud <odyx@debian.org>2019-09-30 20:35:17 +0200
committerDidier Raboud <odyx@debian.org>2019-09-30 20:35:17 +0200
commitf5a3edad8b475d56d62d5779ae6403cc4f46381a (patch)
treec52dba7a0a4bcc9b5c43d18aebb0905cb548876d
parentc0c646678c8de86089712e1ffd0cb49abbfc08de (diff)
parent23117fe9e0266396e4791cdae84d979928aed135 (diff)
Update to upstream 6
[git-debrebase anchor: new upstream 6, merge]
-rw-r--r--.gitignore1
-rw-r--r--CMakeLists.txt2
-rw-r--r--ChangeLog4
-rw-r--r--README.md16
-rw-r--r--brlaser.drv.in45
-rw-r--r--src/job.cc6
6 files changed, 66 insertions, 8 deletions
diff --git a/.gitignore b/.gitignore
index 567609b..5975d97 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1 +1,2 @@
+*~
build/
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 96465e9..5f20c32 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,6 +1,6 @@
cmake_minimum_required(VERSION 3.1)
project(brlaser CXX)
-set(BRLASER_VERSION "5")
+set(BRLASER_VERSION "6")
if (NOT CMAKE_BUILD_TYPE AND NOT CMAKE_CONFIGURATION_TYPES)
message(STATUS "No build type selected, default to RelWithDebInfo")
diff --git a/ChangeLog b/ChangeLog
index 423192c..c22caf1 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,7 @@
+brlaser v6 (2019-09-22)
+ Added support for some more Brother HL-series printers. These printers
+ had glitched output in earlier releases.
+
brlaser v5 (2019-05-18)
Fixed problems with Brother HL-series printers in 600 dpi mode. Thanks
to Onno Kortmann for the fix.
diff --git a/README.md b/README.md
index 226bb54..8c74240 100644
--- a/README.md
+++ b/README.md
@@ -10,8 +10,8 @@ source drivers don't work, this one might help.
This driver has been reported to work with these printers:
-* Brother DCP-1510
-* Brother DCP-1602
+* Brother DCP-1510 series
+* Brother DCP-1600 series
* Brother DCP-7030
* Brother DCP-7040
* Brother DCP-7055
@@ -19,10 +19,16 @@ This driver has been reported to work with these printers:
* Brother DCP-7060D
* Brother DCP-7065DN
* Brother DCP-7080
-* Brother DCP-L2500D
-* Brother DCP-L2540DW
+* Brother DCP-L2500D series
+* Brother DCP-L2520D series
+* Brother DCP-L2540DW series
* Brother HL-1110 series
* Brother HL-1200 series
+* Brother HL-2030 series
+* Brother HL-2140 series
+* Brother HL-2220 series
+* Brother HL-2270DW series
+* Brother HL-5030 series
* Brother HL-L2300D series
* Brother HL-L2320D series
* Brother HL-L2340D series
@@ -32,7 +38,7 @@ This driver has been reported to work with these printers:
* Brother MFC-7360N
* Brother MFC-7365DN
* Brother MFC-7840W
-* Brother MFC-L2710DW
+* Brother MFC-L2710DW series
* Lenovo M7605D
diff --git a/brlaser.drv.in b/brlaser.drv.in
index 19b1db0..1d7ebc8 100644
--- a/brlaser.drv.in
+++ b/brlaser.drv.in
@@ -166,6 +166,14 @@ Option "brlaserEconomode/Toner save mode" Boolean AnySetup 10
}
{
+ ModelName "DCP-L2520D"
+ Attribute "NickName" "" "Brother DCP-L2520D series, $USING"
+ Attribute "1284DeviceID" "" "MFG:Brother;CMD:PJL,HBP;MDL:DCP-L2520D series;CLS:PRINTER;CID:Brother Laser Type1;"
+ Duplex rotated
+ PCFileName "brl2520d.ppd"
+}
+
+{
ModelName "DCP-L2540DW"
Attribute "NickName" "" "Brother DCP-L2540DW series, $USING"
Attribute "1284DeviceID" "" "MFG:Brother;CMD:PJL,HBP;MDL:DCP-L2540DW series;CLS:PRINTER;CID:Brother Laser Type1;"
@@ -189,6 +197,43 @@ Option "brlaserEconomode/Toner save mode" Boolean AnySetup 10
}
{
+ ModelName "HL-2030 series"
+ Attribute "NickName" "" "Brother HL-2030 series, $USING"
+ Attribute "1284DeviceID" "" "MFG:Brother;CMD:PJL,HBP;MDL:HL-2030 series;CLS:PRINTER;"
+ PCFileName "br2030.ppd"
+}
+
+{
+ ModelName "HL-2140 series"
+ Attribute "NickName" "" "Brother HL-2140 series, $USING"
+ Attribute "1284DeviceID" "" "MFG:Brother;CMD:PJL,HBP;MDL:HL-2140 series;CLS:PRINTER;"
+ PCFileName "br2140.ppd"
+}
+
+{
+ ModelName "HL-2220 series"
+ Attribute "NickName" "" "Brother HL-2220 series, $USING"
+ Attribute "1284DeviceID" "" "MFG:Brother;CMD:PJL,HBP;MDL:HL-2220 series;CLS:PRINTER;"
+ PCFileName "br2220.ppd"
+}
+
+{
+ ModelName "HL-2270DW series"
+ Attribute "NickName" "" "Brother HL-2270DW series, $USING"
+ Attribute "1284DeviceID" "" "MFG:Brother;CMD:PJL,PCL,PCLXL;MDL:HL-2270DW series;CLS:PRINTER;CID:Brother Laser Type1;"
+ Resolution k 1 0 0 0 "300dpi/300 DPI"
+ Duplex rotated
+ PCFileName "br2270dw.ppd"
+}
+
+{
+ ModelName "HL-5030 series"
+ Attribute "NickName" "" "Brother HL-5030 series, $USING"
+ Attribute "1284DeviceID" "" "MFG:Brother;CMD:PJL,PCL;MDL:HL-5030 series;CLS:PRINTER;"
+ PCFileName "br5030.ppd"
+}
+
+{
ModelName "HL-L2300D"
Attribute "NickName" "" "Brother HL-L2300D series, $USING"
Attribute "1284DeviceID" "" "MFG:Brother;CMD:PJL,HBP;MDL:HL-L2300D series;CLS:PRINTER;CID:Brother Laser Type1;"
diff --git a/src/job.cc b/src/job.cc
index 440fc6d..6f088ae 100644
--- a/src/job.cc
+++ b/src/job.cc
@@ -105,10 +105,12 @@ void job::encode_page(const page_params &page_params,
for (int i = 1; i < lines && nextline(line); ++i) {
std::vector<uint8_t> encoded = encode_line(line, reference);
- if (!block.line_fits(encoded.size())) {
+ if (block.line_fits(encoded.size())) {
+ block.add_line(std::move(encoded));
+ } else {
block.flush(out_);
+ block.add_line(encode_line(line));
}
- block.add_line(std::move(encoded));
std::swap(line, reference);
}