summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorDavid Sterba <dsterba@suse.cz>2014-10-30 19:06:31 +0100
committerDavid Sterba <dsterba@suse.cz>2014-11-07 17:52:58 +0100
commit86be0aeaf638b1b2c0dd453ff30d4dadd96250ef (patch)
treea8176a17ef7ca1b198572d490ae12ae27109823d /Makefile
parenteffebebb42bb4263d8633b4252ce2ac573f1a7f8 (diff)
btrfs-progs: build, add make target for a build test
A quick check that everything still builds. Signed-off-by: David Sterba <dsterba@suse.cz>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 99b03658..126dc593 100644
--- a/Makefile
+++ b/Makefile
@@ -248,6 +248,13 @@ library-test.static: $(libs_static) library-test.o
@echo " [LD] $@"
$(Q)$(CC) $(CFLAGS) -o library-test-static library-test.o $(LDFLAGS) $(libs_static)
+test-build:
+ $(MAKE) clean-all
+ $(MAKE) library-test
+ -$(MAKE) library-test.static
+ $(MAKE) -j 8 all
+ -$(MAKE) -j 8 static
+
manpages:
$(Q)$(MAKE) $(MAKEOPTS) -C Documentation