summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephane Glondu <steph@glondu.net>2011-08-02 21:35:59 +0200
committerStéphane Glondu <glondu@debian.org>2019-09-01 20:45:55 +0200
commit6806db11733fdd88ca18e0eeb15d269ad2480de9 (patch)
tree32c354b4a0aea3783ca21526df2b873f50b2f773
parenta1f6711ae0bda7a7505587038b6d1cfd6afbdc92 (diff)
Fix FTBFS on bytecode architectures
The new ocaml.m4 defines OCAMLOPT to "no" (instead of not defining it); adapt src/Makefile accordingly. Signed-off-by: Stephane Glondu <steph@glondu.net> Gbp-Pq: Name 0003-Fix-FTBFS-on-bytecode-architectures.patch
-rw-r--r--src/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/src/Makefile b/src/Makefile
index c9c64b7..bc223c7 100644
--- a/src/Makefile
+++ b/src/Makefile
@@ -14,7 +14,11 @@ ifdef LIBPANGOCAIRO_CFLAGS
TARGETS += pangocairo
endif
-all : $(TARGETS) $(if $(OCAMLOPT),opt)
+ifneq ($(OCAMLOPT),no)
+OPT_TARGET = opt
+endif
+
+all : $(TARGETS) $(OPT_TARGET)
opt : $(addsuffix .opt,$(TARGETS))
cairo : cairo.cma libmlcairo.a
@@ -89,7 +93,7 @@ $(call mloptobjs,$(pangocairo_SRC)) : INCFLAGS=-I $(LABLGTKDIR)
install: all
mkdir -p $(DESTDIR)$(INSTALLDIR) $(DESTDIR)$(OCAMLLIB)/stublibs
install -m 644 *.mli *.cmi *.cma lib*.a $(DESTDIR)$(INSTALLDIR)
-ifdef OCAMLOPT
+ifneq ($(OCAMLOPT),no)
install -m644 *.cmxa *.a *.cmx $(DESTDIR)$(INSTALLDIR)
endif
install -m 755 dll*.so $(DESTDIR)$(INSTALLDIR)