summaryrefslogtreecommitdiff
path: root/cli_nant.pm
diff options
context:
space:
mode:
authorMirco Bauer <meebey@debian.org>2009-03-13 23:15:51 +0000
committerMirco Bauer <meebey@debian.org>2009-03-13 23:15:51 +0000
commitfa1d9c98177495380c92b49b55019fd807e1267f (patch)
tree1dcbadad5c817fad0aba2fe054e2e59789dab7cf /cli_nant.pm
parentf3c1e58334a687ba422ae224b59a10771d51f58b (diff)
* cli-nant.make
cli_nant.pm debian/dh_auto_build_nant debian/dh_auto_clean_nant: + Initial implementation of nant integration with debhelper's "dh" tool. Just include /usr/share/cli-common/cli-nant.make in your debian/rules file and you are done!
Diffstat (limited to 'cli_nant.pm')
-rw-r--r--cli_nant.pm16
1 files changed, 16 insertions, 0 deletions
diff --git a/cli_nant.pm b/cli_nant.pm
new file mode 100644
index 0000000..c2c2999
--- /dev/null
+++ b/cli_nant.pm
@@ -0,0 +1,16 @@
+#!/usr/bin/perl
+# debhelper sequence file for cli-common-dev scripts
+
+use warnings;
+use strict;
+use Debian::Debhelper::Dh_Lib;
+
+insert_after("dh_auto_build", "dh_auto_build_nant");
+insert_after("dh_auto_clean", "dh_auto_clean_nant");
+
+remove_command("dh_auto_configure");
+remove_command("dh_auto_build");
+remove_command("dh_auto_test");
+remove_command("dh_auto_clean");
+
+1;