summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFelipe Sateler <fsateler@gmail.com>2015-11-30 10:02:13 -0300
committerSam Hartman <hartmans@debian.org>2019-03-21 10:31:29 -0400
commit9d6ed9fb7bccc513545f0c985d5dc0b9e22fa67d (patch)
treea070415c5caf43e9a2e09c57ccb8263857ad476d
parent2034988ed7c7cc156f720cae8c19d455f2a78542 (diff)
Only link to lua when necessary, and to the correct lib
Lua policy recommends not linking against the lua library, because it doesn't help at all. All lua-using programs will load the library, not the modules. TODO: The csound-lua bridge is not implemented in cmake yet. The csound-lua bridge, on the other hand, needs to link to the library or else it will fail to load. Use the correct library name. Gbp-Pq: Topic debian-specific Gbp-Pq: Name lua-link.diff
-rw-r--r--interfaces/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/interfaces/CMakeLists.txt b/interfaces/CMakeLists.txt
index 023a9fe3..3781be26 100644
--- a/interfaces/CMakeLists.txt
+++ b/interfaces/CMakeLists.txt
@@ -195,7 +195,7 @@ endif()
endif()
if(BUILD_LUA_INTERFACE)
- set(swiglua_LIBS ${LUAJIT_LIBRARY} ${CSOUNDLIB} libcsnd6)
+ set(swiglua_LIBS ${CSOUNDLIB} libcsnd6)
SET_SOURCE_FILES_PROPERTIES(lua_interface.i
PROPERTIES CPLUSPLUS ON