summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDidier Raboud <odyx@debian.org>2021-02-03 16:20:20 +0100
committerDidier Raboud <odyx@debian.org>2021-05-27 08:48:53 +0200
commit182beeca6b9c390b1be069ed5de4033eaf5039ef (patch)
tree61ceaf476879c2840b43b2581d7e9c8d1ab63871
parent7893c273f8037b332b9da964f29b57b84a8bdbf1 (diff)
Debian: Reproducibility: Run testlang for each provided CUPS locale
… and only for these. Of the build environment forces LC_ALL to a non-provided locale, the build will fail.
-rw-r--r--cups/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/cups/Makefile b/cups/Makefile
index 4e2aa6d37..20683499b 100644
--- a/cups/Makefile
+++ b/cups/Makefile
@@ -639,9 +639,9 @@ testlang: testlang.o $(LIBCUPSSTATIC)
lang=`basename $$po .po | sed -e '1,$$s/^cups_//'`; \
$(MKDIR) locale/$$lang; \
$(LN) ../../$$po locale/$$lang; \
+ echo Running language API tests for $$lang...; \
+ LOCALEDIR=locale ./testlang -l $$lang; \
done
- echo Running language API tests...
- LOCALEDIR=locale ./testlang
#