summaryrefslogtreecommitdiff
path: root/winbuild
diff options
context:
space:
mode:
authorAlessandro Ghedini <ghedo@debian.org>2019-08-09 19:40:29 +0100
committerAlessandro Ghedini <ghedo@debian.org>2019-08-09 19:40:29 +0100
commitf8a6c74ab9e572084c3b01fab2977bfc8e925bcb (patch)
tree9352d6a1d046fd1b781bb40f7c1cef68b8652b50 /winbuild
parentb10ac967894740f12278c3918fe7d94394225740 (diff)
New upstream version 7.65.3
Diffstat (limited to 'winbuild')
-rw-r--r--winbuild/BUILD.WINDOWS.txt1
-rw-r--r--winbuild/Makefile.vc14
-rw-r--r--winbuild/MakefileBuild.vc9
3 files changed, 20 insertions, 4 deletions
diff --git a/winbuild/BUILD.WINDOWS.txt b/winbuild/BUILD.WINDOWS.txt
index c75b15c4..1ede14f0 100644
--- a/winbuild/BUILD.WINDOWS.txt
+++ b/winbuild/BUILD.WINDOWS.txt
@@ -86,6 +86,7 @@ where <options> is one or many of:
WITH_CARES=<dll or static> - Enable c-ares support, DLL or static
WITH_ZLIB=<dll or static> - Enable zlib support, DLL or static
WITH_SSH2=<dll or static> - Enable libSSH2 support, DLL or static
+ WITH_PREFIX=<dir> - Where to install the build
ENABLE_SSPI=<yes or no> - Enable SSPI support, defaults to yes
ENABLE_IPV6=<yes or no> - Enable IPv6, defaults to yes
ENABLE_IDN=<yes or no> - Enable use of Windows IDN APIs, defaults to yes
diff --git a/winbuild/Makefile.vc b/winbuild/Makefile.vc
index 26ab9069..9b3b3551 100644
--- a/winbuild/Makefile.vc
+++ b/winbuild/Makefile.vc
@@ -5,7 +5,7 @@
# | (__| |_| | _ <| |___
# \___|\___/|_| \_\_____|
#
-# Copyright (C) 1999 - 2017, Daniel Stenberg, <daniel@haxx.se>, et al.
+# Copyright (C) 1999 - 2019, Daniel Stenberg, <daniel@haxx.se>, et al.
#
# This software is licensed as described in the file COPYING, which
# you should have received as part of this distribution. The terms
@@ -39,9 +39,13 @@ CFGSET=true
!MESSAGE where <options> is one or many of:
!MESSAGE VC=<6,7,8,9,10,11,12,14,15> - VC versions
!MESSAGE WITH_DEVEL=<path> - Paths for the development files (SSL, zlib, etc.)
-!MESSAGE Defaults to sibbling directory deps: ../deps
+!MESSAGE Defaults to curl's sibling directory deps: ../deps
!MESSAGE Libraries can be fetched at https://windows.php.net/downloads/php-sdk/deps/
!MESSAGE Uncompress them into the deps folder.
+!MESSAGE WITH_PREFIX=<path> - Installation directory path
+!MESSAGE Defaults to a configuration dependent (SSL, zlib, etc.)
+!MESSAGE directory inside curl's subdirectory builds: ./builds
+!MESSAGE Use backslashes as path separator
!MESSAGE WITH_SSL=<dll or static> - Enable OpenSSL support, DLL or static
!MESSAGE WITH_NGHTTP2=<dll or static> - Enable HTTP/2 support, DLL or static
!MESSAGE WITH_CARES=<dll or static> - Enable c-ares support, DLL or static
@@ -134,6 +138,12 @@ USE_WINSSL = false
!IFNDEF ENABLE_OPENSSL_AUTO_LOAD_CONFIG
ENABLE_OPENSSL_AUTO_LOAD_CONFIG = true
+!ELSEIF "$(ENABLE_OPENSSL_AUTO_LOAD_CONFIG)"=="yes"
+!UNDEF ENABLE_OPENSSL_AUTO_LOAD_CONFIG
+ENABLE_OPENSSL_AUTO_LOAD_CONFIG = true
+!ELSEIF "$(ENABLE_OPENSSL_AUTO_LOAD_CONFIG)"=="no"
+!UNDEF ENABLE_OPENSSL_AUTO_LOAD_CONFIG
+ENABLE_OPENSSL_AUTO_LOAD_CONFIG = false
!ENDIF
CONFIG_NAME_LIB = libcurl
diff --git a/winbuild/MakefileBuild.vc b/winbuild/MakefileBuild.vc
index 8d942b75..993ab38b 100644
--- a/winbuild/MakefileBuild.vc
+++ b/winbuild/MakefileBuild.vc
@@ -486,8 +486,13 @@ CFLAGS = $(CFLAGS) /DCURL_WITH_MULTI_SSL
!ENDIF
LIB_DIROBJ = ..\builds\$(CONFIG_NAME_LIB)-obj-lib
-CURL_DIROBJ = ..\builds\$(CONFIG_NAME_LIB)-obj-curl
-DIRDIST = ..\builds\$(CONFIG_NAME_LIB)\
+CURL_DIROBJ = ..\builds\$(CONFIG_NAME_LIB)-obj-curl
+
+!IFDEF WITH_PREFIX
+DIRDIST = $(WITH_PREFIX)
+!ELSE
+DIRDIST = ..\builds\$(CONFIG_NAME_LIB)\
+!ENDIF
#
# curl.exe