summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoey Hess <joey@kitenet.net>2012-04-17 16:54:42 -0400
committerJoey Hess <joey@kitenet.net>2012-04-17 16:54:42 -0400
commite7f5f747e04176bda1d0e353eee3e0b5445b70f8 (patch)
treedb04116306245f0efced7016bd895270c8fb433a
parent9926571a5156ca28175544d2b7cf69c926038b21 (diff)
cmake: Only pass CPPFLAGS in CFLAGS in v9.
-rw-r--r--Debian/Debhelper/Buildsystem/cmake.pm2
-rw-r--r--debian/changelog6
2 files changed, 7 insertions, 1 deletions
diff --git a/Debian/Debhelper/Buildsystem/cmake.pm b/Debian/Debhelper/Buildsystem/cmake.pm
index 98029efd..f318b44b 100644
--- a/Debian/Debhelper/Buildsystem/cmake.pm
+++ b/Debian/Debhelper/Buildsystem/cmake.pm
@@ -44,7 +44,7 @@ sub configure {
push @flags, "-DCMAKE_VERBOSE_MAKEFILE=ON";
# CMake doesn't respect CPPFLAGS, see #653916.
- if ($ENV{CPPFLAGS}) {
+ if ($ENV{CPPFLAGS} && ! compat(8)) {
$ENV{CFLAGS} .= ' ' . $ENV{CPPFLAGS};
$ENV{CXXFLAGS} .= ' ' . $ENV{CPPFLAGS};
}
diff --git a/debian/changelog b/debian/changelog
index 86d4565e..7d85a5ef 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+debhelper (9.20120418) unstable; urgency=low
+
+ * cmake: Only pass CPPFLAGS in CFLAGS in v9.
+
+ -- Joey Hess <joeyh@debian.org> Tue, 17 Apr 2012 16:54:39 -0400
+
debhelper (9.20120417) unstable; urgency=low
* cmake: Pass CPPFLAGS in CFLAGS. Closes: #668813