summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorAurélien COUDERC <zecoucou@free.fr>2019-01-29 15:09:50 +0100
committerAurélien COUDERC <zecoucou@free.fr>2019-01-29 15:09:50 +0100
commitbc2175862a0d0a590486c5cfa0cb048638b5ad3a (patch)
tree21f4c4d1dc3c814bcb837a274ab5a337553b3775 /Makefile
parente43094fa37362b475c8039b03739586b05db6004 (diff)
Add lock screen for futurePrototype
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 5e09103..01fa1ee 100644
--- a/Makefile
+++ b/Makefile
@@ -206,6 +206,12 @@ install-local:
cd $(DESTDIR)/usr/share/wallpapers && ln -s /usr/share/desktop-base/futureprototype-theme/wallpaper FuturePrototype
### Lockscreen
- cd $(DESTDIR)/usr/share/desktop-base/futureprototype-theme && ln -s /usr/share/desktop-base/futureprototype-theme/wallpaper lockscreen
+ install -d $(DESTDIR)/usr/share/desktop-base/futureprototype-theme/lockscreen/contents/images
+ $(INSTALL_DATA) futureprototype-theme/lockscreen/metadata.desktop $(DESTDIR)/usr/share/desktop-base/futureprototype-theme/lockscreen
+ $(INSTALL_DATA) futureprototype-theme/lockscreen/gnome-background.xml $(DESTDIR)/usr/share/desktop-base/futureprototype-theme/lockscreen
+ $(INSTALL_DATA) $(wildcard futureprototype-theme/lockscreen/contents/images/*) $(DESTDIR)/usr/share/desktop-base/futureprototype-theme/lockscreen/contents/images/
+ # Lock screen symlink for KDE
+ install -d $(DESTDIR)/usr/share/wallpapers
+ cd $(DESTDIR)/usr/share/wallpapers && ln -s /usr/share/desktop-base/futureprototype-theme/lockscreen FuturePrototypeLockScreen
include Makefile.inc