summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron M. Ucko <ucko@debian.org>2017-01-05 19:53:54 -0500
committerAaron M. Ucko <ucko@debian.org>2017-01-05 19:53:54 -0500
commitcdb13ca391fec7285521391418a80c850e3d6c9a (patch)
tree20c5db60130c916e8a89f90f9a8248c13a43b155
parent826054a191483c7f47df0de8752e1b1282631a28 (diff)
dictionary.el: Support nil dictionary-tooltip-dictionary (#719041).
Per the ever-patient Kevin Ryde <user42@zip.com.au>, adjust dictionary-tooltip-dictionary's defcustom type to acknowledge that nil (the default value) is in fact valid. (Closes: #719041.) Also, tweak dictionary-display-tooltip (used by GNU Emacs) to proceed even if dictionary-tooltip-dictionary is nil, as already done for XEmacs.
-rw-r--r--debian/changelog16
-rwxr-xr-xdictionary.el4
2 files changed, 13 insertions, 7 deletions
diff --git a/debian/changelog b/debian/changelog
index 7326665..5fc5281 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,11 +1,17 @@
dictionary-el (1.10-3) UNRELEASED; urgency=medium
* NOT RELEASED YET.
- * dictionary.el: Per Hermógenes Oliveira <oliveira-guest@alioth.debian.org>,
- adjust buffer-read-only rather than calling toggle-read-only, which is
- deprecated and can have unwanted side effects. (Closes: #850279.)
-
- -- Aaron M. Ucko <ucko@debian.org> Thu, 05 Jan 2017 18:49:59 -0500
+ * dictionary.el:
+ - Per Hermógenes Oliveira <oliveira-guest@alioth.debian.org>,
+ adjust buffer-read-only rather than calling toggle-read-only, which
+ is deprecated and can have unwanted side effects. (Closes: #850279.)
+ - Per the ever-patient Kevin Ryde <user42@zip.com.au>, adjust
+ dictionary-tooltip-dictionary's defcustom type to acknowledge that nil
+ (the default value) is in fact valid. (Closes: #719041.) Also, tweak
+ dictionary-display-tooltip (used by GNU Emacs) to proceed even if
+ dictionary-tooltip-dictionary is nil, as already done for XEmacs.
+
+ -- Aaron M. Ucko <ucko@debian.org> Thu, 05 Jan 2017 19:53:53 -0500
dictionary-el (1.10-2) unstable; urgency=medium
diff --git a/dictionary.el b/dictionary.el
index 9c77e8b..ef820de 100755
--- a/dictionary.el
+++ b/dictionary.el
@@ -1183,7 +1183,7 @@ It presents the word at point as default input and allows editing it."
nil
"This dictionary to lookup words for tooltips"
:group 'dictionary
- :type 'string)
+ :type '(choice (const :tag "Default" nil) string))
(defun dictionary-definition (word &optional dictionary)
(interactive)
@@ -1276,7 +1276,7 @@ It presents the word at point as default input and allows editing it."
(defun dictionary-display-tooltip (event)
"Search the current word in the `dictionary-tooltip-dictionary'."
(interactive "e")
- (if dictionary-tooltip-dictionary
+ (if t ; dictionary-tooltip-dictionary
(let ((word (save-window-excursion
(save-excursion
(mouse-set-point event)