summaryrefslogtreecommitdiff
path: root/script/Jenkinsfile.fossa
diff options
context:
space:
mode:
authorFelipe Sateler <fsateler@debian.org>2019-11-22 21:15:41 -0300
committerFelipe Sateler <fsateler@debian.org>2019-11-22 21:15:41 -0300
commit97b16e5404375cc6cca4469045984cac0eabd335 (patch)
treeb9cfdfec00f4a6afceed718cbb155651d23a51fc /script/Jenkinsfile.fossa
parent813ff34b5328e530d94c95cd8235431cde391e4c (diff)
parentd66f980dd002ce94c3196b1a74dc8c1a0788be06 (diff)
Update upstream source from tag 'upstream/1.25.0'
Update to upstream version '1.25.0' with Debian dir 01225dadf264cb86293071829641cb341942031d
Diffstat (limited to 'script/Jenkinsfile.fossa')
-rw-r--r--script/Jenkinsfile.fossa20
1 files changed, 20 insertions, 0 deletions
diff --git a/script/Jenkinsfile.fossa b/script/Jenkinsfile.fossa
new file mode 100644
index 00000000..480e98ef
--- /dev/null
+++ b/script/Jenkinsfile.fossa
@@ -0,0 +1,20 @@
+pipeline {
+ agent any
+ stages {
+ stage("License Scan") {
+ agent {
+ label 'ubuntu-1604-aufs-edge'
+ }
+
+ steps {
+ withCredentials([
+ string(credentialsId: 'fossa-api-key', variable: 'FOSSA_API_KEY')
+ ]) {
+ checkout scm
+ sh "FOSSA_API_KEY='${FOSSA_API_KEY}' BRANCH_NAME='${env.BRANCH_NAME}' make -f script/fossa.mk fossa-analyze"
+ sh "FOSSA_API_KEY='${FOSSA_API_KEY}' make -f script/fossa.mk fossa-test"
+ }
+ }
+ }
+ }
+}